X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Will Firefox 3.x work with Windows XP SP1?

Posted

I would like to upgrade Firefox 2.0.0.20 but I have XP SP1. For various reasons I do not want to update to SP2 or SP3. Will Firefox 3.x work with Windows XP SP1?

Also, if I upgrade from with Firefox 2.0.0.20, will it uninstall the existing Firefox and import all of the settings and bookmarks into Firefox 3.x?

Additional System Details

This happened

Not sure how often

Installed Plug-ins

  • Default Plug-in
  • LabVIEW 8.5 Netscape Plug-in for Win32
  • LabVIEW 8.2 Netscape Plug-in for Win32
  • Shockwave Flash 10.0 r45
  • Adobe Acrobat Plug-In Version 5.00 for Netscape
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

It will work on XP SP1. By default it will overwrite the Firefox 2 application, but will use your current Firefox settings such as bookmarks and passwords.

If you have previously tried to use Firefox 3.* on this computer you will likely have problems, it will use data from the previous time you tried to use Firefox 3.*

If you have previously installed Firefox 3.* see this link - Firefox 3 upgrade switches bookmarks and other settings to older version