X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 4.ob10 Mac: The "Save Tabs?" does not appear when quitting FF

Posted

I have disabled all extentions, add-ons, started up in Safe Mode or tried any other suggestions placed on the forum, but still, tabs are not saved.

I don't find a "enable" or "disable Save Tabs" in the preferences

As suggested, in the profile folder I have renamed the formhistory.sqlite to formhistory.sqlite.bak and sessionstore.js to sessionstore.js.bak

No saving of Tabs. Any suggestion? Tkx Yve

I have disabled all extentions, add-ons, started up in Safe Mode or tried any other suggestions placed on the forum, but still, tabs are not saved. I don't find a "enable" or "disable Save Tabs" in the preferences As suggested, in the profile folder I have renamed the ''formhistory.sqlite ''to ''formhistory.sqlite.bak'' and sessionstore.js to sessionstore.js.bak No saving of Tabs. Any suggestion? Tkx Yve

Chosen solution

The prefs for Save & Quit the warning message have been set by default to false in current Firefox 4 beta versions (Bug 592822 - Remove quit warning dialog).

You can set the warn prefs on the about:config page to true via the right-click context menu or toggle with a double left-click.


Read this answer in context 59

Additional System Details

This happened

Every time Firefox opened

This started when...

a few days ago

Installed Plug-ins

all disabled

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

John99 971 solutions 13138 answers

Maybe this point is Moot now we are using Firefox 4RC1. I have not really tried to follow the Bug s but obviously work would appear to be in progress, but it seems to me the problem is effectively fixed.

I suspect there is now no need to make changes with about:config
( I am sure someone will correct me if I am wrong)


  • The save by default may need resetting, when you first install the RC ( was Beta) 4 , and you may need to check the warn on closing multiple tabs option
  • On the current install I have of 4RC1 I have it set to save tabs on exit, but have not changed any of the preferences explicitly using about:config and it is behaving differently from Firefox3.6 but NOT loosing the OPEN tabs the following happens
    1. On closing it warns I am closing multiple tabs, but does not give an option to save or quit, it just closes down
    2. On reopening, it opens with the home page BUT it has a prominent option to restore previous session.


Latest bugs I have noted are Bug 593421 leading to Bug 65231 - "Prompt for session-handling on exit" [Obviously these are for developers and coders to comment not us ordinary users - but I often find some of them informative reading]

Maybe this point is Moot now we are using Firefox 4RC1. I have not really tried to follow the Bug s but obviously work would appear to be in progress, but it seems to me the problem is effectively fixed. I suspect there is now no need to make changes with about:config <br /> ( I am sure someone will correct me if I am wrong) * The save by default may need resetting, when you first install the RC ( was Beta) 4 , and you may need to check the warn on closing multiple tabs option * On the current install I have of 4RC1 I have it set to save tabs on exit, but have not changed any of the preferences explicitly using about:config and it is behaving differently from Firefox3.6 but NOT loosing the OPEN tabs the following happens *# On closing it warns I am closing multiple tabs, but does not give an option to save or quit, it just closes down *# On reopening, it opens with the home page BUT it has a prominent option to restore previous session. Latest bugs I have noted are Bug 593421 leading to '''Bug 65231 - "Prompt for session-handling on exit" ''' [Obviously these are for developers and coders to comment not us ordinary users - but I often find some of them informative reading]

Question owner

John 99, there are 2 ways of closing FF. If you simply close the window (but not FF4RC) it will warn you that you you are closing multiple tabs, no other choice. But if you quit the FF4RC application, it will ask you if you want to save the tabs (APP pins are always maintained until you reload them as tabs (Ctrl click the tab). But YOU MUST change the browser.showQuitWarning in about:conf from false to true and restart FF if you want the pop up for saving the tabs top appear. I think with 4RC default is still set on false. And of course there is still the Restore previous session in the History menu shold something go wrong. Hope this helps Yve

John 99, there are 2 ways of closing FF. If you simply close the window (but not FF4RC) it will warn you that you you are closing multiple tabs, no other choice. But if you quit the FF4RC application, it will ask you if you want to save the tabs (APP pins are always maintained until you reload them as tabs (Ctrl click the tab). But YOU MUST change the ''browser.showQuitWarning'' in about:conf from false to true and restart FF if you want the pop up for saving the tabs top appear. I think with 4RC default is still set on ''false''. And of course there is still the ''Restore previous session'' in the History menu shold something go wrong. Hope this helps Yve

Modified by ylegler

John99 971 solutions 13138 answers

Thanks for the reply Yve,

As I see it
If I set it to do so, Firefox 4RC1 WILL warn me I am closing multiple tabs,

  • when I close a window
  • or when I close a final window or the application

The 4RC1 browser.showQuitWarning is apparently set to false by default. I was just pointing out thet even if that is NOT toggled, to true, in about:config

  1. firefox 4RC1 will still quit without loosing information.
  2. firefox 4RC1 will still offer prominently to restore the preveous session

The prominent restore sesion option displays in the cetre of the page, so even anyone unaware of the History options sees it. The browsershowQuitWarning is useful but data is not lost if the warning is not toggled.

John

Thanks for the reply Yve, As I see it <br />If I set it to do so, Firefox 4RC1 WILL warn me I am closing multiple tabs, *when I close a window * or when I close a final window or the application The 4RC1 ''browser.showQuitWarning'' is apparently set to false by default. I was just pointing out thet even if that is NOT toggled, to true, in about:config #firefox 4RC1 will still quit without loosing information. #firefox 4RC1 will still offer prominently to restore the preveous session The prominent restore sesion option displays in the cetre of the page, so even anyone unaware of the History options sees it. The browsershowQuitWarning is useful but data is not lost if the warning is not toggled. John

Question owner

Thanks John for the corrected info

Yve

Thanks John for the corrected info Yve
johnzilla 0 solutions 7 answers

The problem with the restore button is if you open and close FF without restoring the last session yer SOL. A good example would be you close FF, next time you open FF there are updates to some extensions and you forgot that you wanted yer last tabs. You install the updates and restart FF. Everything's gone. :/ That's why the save tabs and quit option has no proper workaround. Anytime FF is properly closed with multiple tabs, you're prompted to save, leaving any accidental user error out of the question.

The problem with the restore button is if you open and close FF without restoring the last session yer SOL. A good example would be you close FF, next time you open FF there are updates to some extensions and you forgot that you wanted yer last tabs. You install the updates and restart FF. Everything's gone. :/ That's why the save tabs and quit option has no proper workaround. Anytime FF is properly closed with multiple tabs, you're prompted to save, leaving any accidental user error out of the question.
johnzilla 0 solutions 7 answers

@ Yve

Can ya set one of the proper replies as a solution so that people viewing the thread can see the answer to the problem? Right now it's buried in there and might not be seen.

@ Yve Can ya set one of the proper replies as a solution so that people viewing the thread can see the answer to the problem? Right now it's buried in there and might not be seen.

Question owner

John, where do I set one of your proper replies as a solution? The only button I could find is Helpful, which I clicked. Maybe it is not the way to go, I am not to familiar with these Forums. Of course I'd like people to see your solution. Yve

John, where do I set one of your proper replies as a solution? The only button I could find is Helpful, which I clicked. Maybe it is not the way to go, I am not to familiar with these Forums. Of course I'd like people to see your solution. Yve
John99 971 solutions 13138 answers

This matter has been discussed in another [forum]

Rather confusing and unhelpful at present, you need to be logged in, once you sign in if you use the helpful button and are the 'owner' of the thread it is marked as solved.

Once marked as solved, you can not currently change it, but you, or anyone else (not even certain you need to be signed in currently), may add another post to the helpful list if you wish. The number of clicks are counted, and posts may move up if they are clicked more often as helpful.

BTW I understand an update to the forum is due anytime now, do not be surprised if it goes down for a short while today.

This matter has been discussed in another [[https://support.mozilla.com/en-US/forums/contributors/704952?page=2#post-10369 forum]] Rather confusing and unhelpful at present, you need to be logged in, once you sign in if you use the helpful button and are the 'owner' of the thread it is marked as solved. Once marked as solved, you can not currently change it, but you, or anyone else (not even certain you need to be signed in currently), may add another post to the helpful list if you wish. The number of clicks are counted, and posts may move up if they are clicked more often as helpful. BTW I understand an update to the forum is due anytime now, do not be surprised if it goes down for a short while today.

Modified by John99

Question owner

Understand, thx. I did close the case (solution) weeks ago and of course received additional information emails later on which prompted me to reply. Guess I can't close it twice, but marked as Helpful.

Understand, thx. I did close the case (solution) weeks ago and of course received additional information emails later on which prompted me to reply. Guess I can't close it twice, but marked as Helpful.
chrisjsevans 0 solutions 6 answers

browser.warnOnQuit didn't fix it for me:-( I also then noticed that links that i had visisted on pages were no longer red when I reloaded a page the next day. So as I was still concerened as to why every time i went to about:config more and more entries were not default, I've gone back to FF3. I'd expected a 'release candidate' to be more finished! n.b. I left FF4 sitting there as the only app running and didn't touch it, an hour later FF4 memory useage had increased 50%!

browser.warnOnQuit didn't fix it for me:-( I also then noticed that links that i had visisted on pages were no longer red when I reloaded a page the next day. So as I was still concerened as to why every time i went to about:config more and more entries were not default, I've gone back to FF3. I'd expected a 'release candidate' to be more finished! n.b. I left FF4 sitting there as the only app running and didn't touch it, an hour later FF4 memory useage had increased 50%!
John99 971 solutions 13138 answers

@ chrisjsevans,
This thread has a title and a chosen solution.

You may do better to start your own question about your own problem. The problem you see may relate more to your own machine and how it is setup, than to any problem with Firefox itself.

@ chrisjsevans, <br /> This thread has a title and a chosen solution. You may do better to start your own question about your own problem. The problem you see may relate more to your own machine and how it is setup, than to any problem with Firefox itself.
johnzilla 0 solutions 7 answers

@ chrisjsevens

The correct config to change is browser.showQuitWarning.

@ Yve

Sorry, thought you had control over the solution. Maybe you could try editing your problem to also show the solution to prevent people from missing the answer.

@ chrisjsevens The correct config to change is browser.showQuitWarning. @ Yve Sorry, thought you had control over the solution. Maybe you could try editing your problem to also show the solution to prevent people from missing the answer.
holrider 0 solutions 2 answers

Received this info from a chat person. change the setting in Options->General to "show my windows/tabs from last time" I should say when Firefox starts and will give you the option of homepage or above. =D

Received this info from a chat person. change the setting in Options->General to "show my windows/tabs from last time" I should say when Firefox starts and will give you the option of homepage or above. =D
holrider 0 solutions 2 answers

Solution: Received this info from a chat person: Change the setting in Tools>Options->General to "show my windows/tabs from last time".

It should say "when Firefox starts" and will give you the option 

of homepage or show my windows/tabs from last time or show blank page. =D

Solution: Received this info from a chat person: Change the setting in Tools>Options->General to "show my windows/tabs from last time". It should say "when Firefox starts" and will give you the option of homepage or show my windows/tabs from last time or show blank page. =D

Modified by holrider

elstumpo 0 solutions 2 answers

If those solutions don't work:
Load about:config toggle browser.startup.page to 3.
FF will automatically restore your last session on start up (rather than your home page).

If those solutions don't work:<br /> Load about:config toggle browser.startup.page to 3.<br /> FF will automatically restore your last session on start up (rather than your home page).

Modified by elstumpo

mmarchid 0 solutions 7 answers

I completely disagree with all these gymnastics flip-flops of emulating some real useful functionality. How about just restore that simple, clear and useful functionality?

All your posts and answers that nothing is lost do not address the scenarios mentioned here https://support.mozilla.com/en-US/kb/ask/discuss/616#post-940

therefore I am pleading to you to cave in to your loyal users' requests for the return of that functionality. I am not really asking for support here, this is a last minute call for a reality touch on Mozilla behalf or bye-bye FF after 6 years.

I have never thought I would be so angry about any product, yet alone about FF, that aberrant are these decisions you made in the past 2 months. You could have done a million other changes and I wouldn't have cared, that is what loyalty by inertia is, there were VERY FEW STUPID decisions you could have done to completely annoy your users and you have just done that very well.

I completely disagree with all these gymnastics flip-flops of emulating some real useful functionality. How about just restore that simple, clear and useful functionality? All your posts and answers that nothing is lost do not address the scenarios mentioned here https://support.mozilla.com/en-US/kb/ask/discuss/616#post-940 therefore I am pleading to you to cave in to your loyal users' requests for the return of that functionality. I am not really asking for support here, this is a last minute call for a reality touch on Mozilla behalf or bye-bye FF after 6 years. I have never thought I would be so angry about any product, yet alone about FF, that aberrant are these decisions you made in the past 2 months. You could have done a million other changes and I wouldn't have cared, that is what loyalty by inertia is, there were VERY FEW STUPID decisions you could have done to completely annoy your users and you have just done that very well.

Modified by mmarchid

Anney 0 solutions 1 answers

Best answer, it works and it's easy, thanks a lot!

Best answer, it works and it's easy, thanks a lot!
daver 0 solutions 1 answers

Hi Yve and Johnsilla. Thank you indeed for your input on this problem. I now have the "Save and Quit" function back. I have NO idea why the Mozilla Team would have removed this (or left the config default as "false"). It is one of the best features on FF and why I have always preferred FF to IE9. Come on Mozilla - put the function back as a default. Daver

Hi Yve and Johnsilla. Thank you indeed for your input on this problem. I now have the "Save and Quit" function back. I have NO idea why the Mozilla Team would have removed this (or left the config default as "false"). It is one of the best features on FF and why I have always preferred FF to IE9. Come on Mozilla - put the function back as a default. Daver

Question owner

Just a short note to mmarchid: This is a problem solving/discussing Forum, not a public display of anger site. You don't like Firefox? Use another browser, that simple. There are millions of people who use FF. There must be a reason for this!

Just a short note to '''mmarchid''': This is a problem solving/discussing Forum, not a public display of anger site. You don't like Firefox? Use another browser, that simple. There are millions of people who use FF. There must be a reason for this!

Question owner

@Anney, don't know if your reply was an ironic one to mmarchid. If you solved your tabs situation, fine. If not, please go to the top of this forum and select 'Solution Chosen by ylegler' which contains the links to the tabs solution. Yve

@Anney, don't know if your reply was an ironic one to mmarchid. If you solved your tabs situation, fine. If not, please go to the top of this forum and select 'Solution Chosen by ylegler' which contains the links to the tabs solution. Yve