X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4.ob10 Mac: The "Save Tabs?" does not appear when quitting FF

Posted

I have disabled all extentions, add-ons, started up in Safe Mode or tried any other suggestions placed on the forum, but still, tabs are not saved.

I don't find a "enable" or "disable Save Tabs" in the preferences

As suggested, in the profile folder I have renamed the formhistory.sqlite to formhistory.sqlite.bak and sessionstore.js to sessionstore.js.bak

No saving of Tabs. Any suggestion? Tkx Yve

Chosen solution

The prefs for Save & Quit the warning message have been set by default to false in current Firefox 4 beta versions (Bug 592822 - Remove quit warning dialog).

You can set the warn prefs on the about:config page to true via the right-click context menu or toggle with a double left-click.


Read this answer in context 59

Additional System Details

This happened

Every time Firefox opened

This started when...

a few days ago

Installed Plug-ins

all disabled

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Chosen Solution

The prefs for Save & Quit the warning message have been set by default to false in current Firefox 4 beta versions (Bug 592822 - Remove quit warning dialog).

You can set the warn prefs on the about:config page to true via the right-click context menu or toggle with a double left-click.


Modified by cor-el

Question owner

Thanks After changing the 'browser.warnOnQuit' from false to true in the 'about.conf' page, tabs are saved again. Thank you again Yve

leegero 0 solutions 1 answers

I have a Mac. How do I access the about:config page so I can set this to the right settings? Thanks in advance.

Question owner

If you are trying to set the SAVE TABS in the preferences (about:config), it is not necessary anymore in the new Firefox 4.0b12 version. This version includes a possibility to Pin the individual Tabs as an APP TAB (small square on the left of the tabs) which will remain when you shut Firefox. No more "do you want to save tabs" question. APP TABS stay right where they are. Very practical. On the Mac, click control+Tab and select Pin as APP TAB in the popup menu. As far as reaching the about:config, I did it but don't remember how.... sorry Yve

Question owner

How to go to about:config page Found it again. Open Firefox and type the following in the URL address: <about:config> end hit enter. There you will have all the lists of preferences. Ciao Yve

oldpink 0 solutions 1 answers

I went to both the standard preferences menu and the about:config to see if I could force it to prompt when closing, but to no avail, even though I ensured all appropriate warns were toggled on. There is clearly a bug in the latest betas. I first noticed this in the 4.0 Beta 10 version.

Question owner

I checked it again and in my case it does work. In FF URL address (top line) enter "about:config" and hit enter. A message appears saying something about voiding warranty. Click OK and the config page appears. Under "Filter" type "browser.warnOnQuit". When it appears it should read: browser.warnOnQuit Status: default Type: boolean Value: true Restart FF and it should work. I see that you are using FF beta 4.01. As mentioned before, install beta 4.0b12 which you can download on the FF site and I believe this has been corrected by default. And with the app Tab innovation, you don't need it anymore anyhow, but it still gives you the warning. Yve

colin_c_w 0 solutions 4 answers

Helpful Reply

@ylegler

For me, app tab doesn't do what I want. I often have upwards of 30 (temporary) tabs open (thank you Panorama!) and I may have to restart my computer, want Firefox closed temporarily to regain some RAM or eek out some battery life on my laptop, however I do want those tabs to open again. Telling FF on quit to reopen them next time is a beautifully simple operation.

To go through every tab, tell it to save as app tab, then when FF is back up have to make it a normal tab again just to close it is extremely annoying and impractical when dealing with large numbers of temporary tabs.

I fully see the purpose of app tabs, but for this situation they do not apply at all.

Question owner

OK, I understand what you mean. So the other solution is to quit FF without saving whatever tabs you have and do what ever (such as regain RAM). When you restart FF, go under History in the main menu and select "Restore previous session" and it will bring you back where you where before quitting.

Yve

colin_c_w 0 solutions 4 answers

Ok fair enough. Still don't find it as simple as saying "save and quit" when closing, but it definitely works!

Thanks for the help and quick reply!! :D

Colin

ksinsac 0 solutions 1 answers

I understand the change to pinned apps, but what if that doesn't do what we want...can the "Save tabs" option be renewed? It was put there way back for a reason...I don't want to have to "pin" 20-30 tabs for a quick close.

colin_c_w 0 solutions 4 answers

@ksinsac

I asked this exact question just above your post and ylegler has provided a solution already. Please be sure to read what has already been discussed/answered before asking something yourself. :)

Although I would like to add that it would be nice to have an option in about:config to enable the dialog again. That way it's not on by default since that seems to be the way FF is going, but it can still be enabled for those who want it.

chrisjsevans 0 solutions 6 answers

Mmm I tried that (Just setting 'browser.warnOnQuit' to true) next reload I only got my home page. I used History, restore last session to get back all my tabs n.b. I'd been able to use 'restore previous session' before the restart as well, which AIUI shouldn't have worked, as I'd allready shutdown FF4 once without these changes! Anyway I then toggled browser.tabs.warnOnClose & browser.warnOnRestart Shutdown, restart (I tried just closing firefox but 3 of the 4 times I've done that since upgrading to FF4, whilst disappearing from Applications in task manager it hasn't gone from Process) On restarting still only the home page being loaded, so I used 'restore previous session'. I looked again at About:config' this time Dozens of setting are Bold and marked 'User Set'. Is there easy way to reset them all to default, I've tried doing them one by one but some of the 'defaults' look suspect e.g. browser.cache.disk.smart_size_cached_value is defaulting to 'String' with a blank 'Value' I'm not sure what is going to happen next boot up.... Help please.

Question owner

I'm just as frustrated as you are (and many others as well) regarding saving Tabs. It just doesn't work, even when selecting "browser.warnOnQuit" with true. The "restore previous session" does work, but it is a work around of a problem. A great and successful browser like FF should really have this option available as it was in FF3. Mozilla, wake up. Can't you find a solution to this please? Many surfers complain about it

johnzilla 0 solutions 7 answers

Helpful Reply

Hey, I don't really ever use save tabs (very rarely). Girlfriend, sister, others I know use it a lot. I've shown them FF 4 and they hate it because of the lack of it. I forgot all about about:config cause I barely use it. I was just skimming through to see what I could find and it looks like I've found the dang option :) Surprised no one else found it, or maybe they have but I haven't seen it when searching. Anyways, the config is:

browser.showQuitWarning. Enjoy :)

Modified by johnzilla

colin_c_w 0 solutions 4 answers

@johnzilla

That is definitely it!!!!!!!! Good catch! :D

Thank you so much!!! FF4 just got even more awesome now (or at least back to where it was)!

JimIsFoxy 0 solutions 1 answers

Thanks johnzilla, glad I googled the issue and had the patience to read all of the comments, yours especially!

johnzilla 0 solutions 7 answers

No problem. Glad to have helped :)

Question owner

Johnsilla, I was the one opening the topic to begin with and I had found the solution after just a few exchanges, but then it lost it again.... Instead of browser.showQuitWarning I had selected browser.warnOnQuit! Finally, thanks to you, we can put the topic to sleep! See yah Yve

johnzilla 0 solutions 7 answers

Hey Yve, you might want to mark it as the solution so others can benefit from the thread. Thanks.