X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Add-on Manager freezes Firefox when I open it.

Posted

I am using Linux Mint 10 and Firefox 4b11pre, although this has been happening since at least b9pre. I am running Fx from my home folder as downloaded from Mozilla, not from a PPA. This happens on the "stable" beta releases as well as the "pre" releases. I used to be able to "vacuum" the databases with the program Bleachbit and the problem would go away...for a while. Now that is no longer affective.

Also, and I think this is important, ALL add-ons are functioning correctly. Everything works except I cannot open the add-on manger.

The new (huge, cumbersome, and unresponsive) add-on manager simply stops working. It won't load or partially loads and the browser darkens, which signifies an unresponsive program in Linux. I then have to force quit Firefox.

If I have crash reporting enabled I am never asked to submit a report.

This occurs completely randomly. It is not associated with any particular add-on as far as I can tell. I have spent many hours trying to diagnose this problem to no avail.

Things I've already done:

1. Build a completely fresh profile. I have done this several times, combining many different settings, and the problem still happens. It happens with the default settings, when I only change settings from the Preferences dialog, and when I change settings through about:config. I have also used the safe-mode switch to reset all settings, but it still happens. Similarly, I have re-downloaded Firefox itself, "pre" and "stable" for fear of corruption by updates, which has happened before, but this does not solve anything either.

2. Safe mode. If I choose to disable all add-ons from the safe mode dialog and restart Firefox the add-on manager works. At any given time I have about 30 add-ons enabled, mostly the standard ones (Adblock, No Script, etc.), and many that I'm just playing around with.

Now, when I start to enable add-ons, the add-on manager works. I can enable, say, 5 at a time, completely randomly, and it will continue to work until I reach about 25, then it dies. I have removed all add-ons except the ones approved by Mozilla on there add-ons website. Then with all approved add-ons (and a still not working manager) I have disabled all add-ons, restarted, and enabled them one by one. Enable, restart. Enable, restart. Then, randomly, it just doesn't work anymore and freezes. I have done this many times and in totally random orders. It does not happen on any specific add-on, and always happens some where between 21 and 27 enabled. You can imagine how frustrating this is, since the add-on manager offers no way to mass-enable or count add-ons.

Finally, I receive no red flags in the error console and have exhausted my Firefox debugging knowledge. I receive no errors when running from the terminal either. As I said, all add-ons are functioning correctly. I have done other combinations of things, if it's a logical off-shoot of anything I mentioned above then I've likely done it. I've searched everywhere, Bugzilla, Google, individual add-on bugs, etc. to no avail.

Sorry this was so long, but if I can't manage my add-ons there's simply no reason to continue using Firefox, but, since it's normally the best browser around, I don't want to face that option. Any help would be greatly appreciated.

Additional System Details

Installed Plug-ins

  • The next generation Java plug-in for Mozilla browsers.
  • The Totem 2.32.0 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • Shockwave Flash 10.2 d161
  • Version 1.1.5 The Luggage, copyright 1996-2007 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:2.0b11pre) Gecko/20110129 Firefox/4.0b11pre

More Information

Application Basics
Name
Firefox
Version
4.0b11pre
User Agent
Mozilla/5.0 (X11; Linux i686; rv:2.0b11pre) Gecko/20110129 Firefox/4.0b11pre
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Firebug
1.7X.0a9
true
firebug@software.joehewitt.com
Greasemonkey
0.9.1
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Stylish
1.1
true
{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
FlashGot
1.2.8.1
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
FireGestures
1.6.1
true
firegestures@xuldev.org
Add Bookmark Here ²
4.0.20110115b1
true
abhere2@moztw.org
Tile Tabs
4.7
true
tiletabs@DW-dev
Console²
0.7
true
{1280606b-2510-4fe0-97ef-9b5a22eafe80}
NoScript
2.0.9.6
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
absolute load control
0.12
true
absolute@load.control.am
Find All
3.2
true
findall@codedawn.com
QuickFox Notes
2.4D
true
amin.eft_bmnotes@gmail.com
Textarea Cache
0.7.1
true
{578e7caa-210f-4967-a0d3-88fe5b59a39f}
SortPlaces
1.7.2
true
sortplaces@andyhalford.com
Who stole my pictures?
0.0.5
true
images@wink.su
Mozilla Labs: Prospector - Home Dash
2
true
home.dash@prospector.labs.mozilla
Element Hiding Helper for Adblock Plus
1.1.1pre2.308
true
elemhidehelper@adblockplus.org
Adblock Plus
1.3.5a2.2767
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Prism for Firefox
1.0b3
false
refractor@developer.mozilla.org
Download Statusbar
0.9.7.2
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Xmarks
3.9.5
true
foxmarks@kei.com
Biscuit
1.4.1
true
biscuit@nuko.org
LastPass
1.72.0
true
support@lastpass.com
Stylish-Custom
0.7.6
true
Stylish-Custom@choggi.dyndns.org
Memory Restart
1.1
true
memoryrestart@teamextension.com
Session Manager
0.7
true
{1280606b-2510-4fe0-97ef-9b5a22eafe30}
Omnibar
0.7.2.20110110
true
omnibar@ajitk.com
Foxy Detective
0.1.3
true
foxydetective@example.org
ViewSourceWith
0.7.3
true
{eecba28f-b68b-4b3a-b501-6ce12e6b8696}
yExplore
2.1.0
true
{8FEC1892-C31B-11DA-B6D0-5A0D0E31F120}
Puzzle
0.4.5
true
puzzle@internauta1024a.pl
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110129030338
browser.startup.homepage_override.mstone
rv:2.0b11pre
browser.tabs.closeButtons
2
browser.tabs.warnOnClose
false
dom.report_all_js_exceptions
true
extensions.lastAppVersion
4.0b11pre
network.cookie.prefsMigrated
true
network.dns.disableIPv6
true
network.dnsCacheEntries
1000
network.dnsCacheExpiration
7200
network.http.max-connections
48
network.http.max-connections-per-server
24
network.http.max-persistent-connections-per-server
12
network.http.pipelining
true
network.http.pipelining.maxrequests
8
network.http.pipelining.ssl
true
network.http.proxy.pipelining
true
places.database.lastMaintenance
1296212101
places.history.expiration.transient_current_max_pages
20987
privacy.cpd.cookies
false
privacy.cpd.extensions-sessionmanager
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
GPU Accelerated Windows
0/1

Question owner

I believe I have solved my own problem. The reason it seemed random was because it was many add-ons causing the problem. Namely these: Biscuit, Download Statusbar, Foxy Detective, Memory Restart, Omnibar, Puzzle, Stylish Custom, and Yexplore. Also affected is Mozilla's own Add-on Compatibility Reporter, although I didn't have it installed, as a test I installed it and it also froze my add-on manager.

I am not a developer. That said, this is what seems to be the problem. It is easily reproducible, I just have to install one of the offending add-ons. I deleted the file "compatibility.ini" in my profile folder and restarted Firefox. Suddenly the above mentioned add-ons were disabled and marked incompatible. However, they are all flagged as compatible on Mozilla's website.

So I deleted them all from my profile, along with all the "extension.*" files and "compatibility.ini" again. After a restart everything worked fine. Then I tried to install Download Statusbar again. After a restart the add-on manager froze again. So I took a peak in the Download Statusbar extension archive. The install.rdf file's max version is below 4b11pre.

So I removed it. Everything worked correctly again. Angry, I literally checked all 23 of my other add-on's install.rdf files. All if them were either "4.0.*" or "4b11pre".

Then I downloaded all the above mentioned add-ons to my desktop and checked their install.rdf files. They are ALL BELOW 4b10. This also happens with 4b10, consequently.

I tried to install them all, one by one, and they all individually broke my add-on manager, even though they installed as compatible. And yes, I have add-on compatibility checking enabled. Please note, the add-ons work fine, but the add-on manager breaks, which essentially cripples Firefox.

Also, changing the version # in the offending install.rdf files does NOT fix the problem, so I assume there is more to it, but again, not a developer. I am amazed that I am the only one with this problem.

Interestingly, I can disable add-on compatibility checking and install add-ons that are not marked compatible and everything works fine. It seems this is some internal problem that only affects add-ons marked as compatible but really aren't...even though they are.

Modified by deadite81

the-edmeister
  • Top 10 Contributor
  • Moderator
3194 solutions 24384 answers

That situation has been mentioned by a few other users, but not in any great numbers. This is what I suspect you have goin' on.

1. If you are using the same Profile with stable and pre-release / beta versions, you are probably causing that problem.

2. I seriously doubt that every extension that you have installed has 4.0.* or 4.0b11pre as the maxVersion in each extension's own install.rdf file. 4.0.* has only been allowed for like 3 or 4 weeks now by AMO, and 4.0b11pre just came about at the beginning of this past week. A "bump" to the maxVersion isn't applied directly to the install.rdf file, but is done in the AMO Extension Developers Control Panel by each developer, for each addon, and it affects the compatibility database that Firefox queries for that information during the installation procedure, and after the Firefox version number is changed your problem starts (like after a Firefox update, or after the user opens that Profile with a different version than what appears in the compatibility.ini file in that Profile.)

I just downloaded the Download Statusbar extension and opened the install.rdf file which is dated 2010-10-03, and it shows 4.0b8pre. On that date the AMO server would have rejected a higher maxVersion that what was available from Mozilla for any extension being uploaded.

3. max Version "compatibility" information is stored in the extensions.sqlite file in Firefox 4.0 beta / pre versions; where as, 3.6 and earlier used extensions.rdf for keeping that information. Firefox has to contact the AddonsMozilla.Org server for verifying compatibility information and updating those files, so you need to be connected to the internet, and you might need to use the Find Updates button at the bottom of the Extension Manager window to force Firefox to look at the AMO server for the correct version information. If you are switching back and forth between 3.6.x and a 4.0 beta / pre Firefox is having a problem probably due to the old RDF & new SQLITE files.


Create a new profile exclusively for the 4.0 beta version and create a desktop shortcut with -P "profile" appended to the target to launch that profile.

Question owner

Thanks for the answer the-edmeister. I am aware that using 3.6 and 4.0 on the same profile breaks things. I don't do it and never have. In fact I don't use 3.6 at all. What's the point? The only reason I know that it happens with b10 is because I downloaded it just to see. I have been using exclusively pre versions for quite some time with little issue.

As for the version numbers, thanks for explaining that a bit more. I can see that it goes deeper than the .rdf, but I have to reiterate that all 23 of the add-ons that don't break the add-on manager have the correct version number or "4.0.*" They are all popular add-ons that are updated regularly, so if you choose to "doubt" that's up to you :) Installing any of the offending add-ons breaks the add-on manager...EVEN ON A FRESH PROFILE. This may be some crazy fluke, but it happens on every fresh profile I make. "Fresh" meaning starting completely from scratch; I do not import one single thing from the old profile. I had hoped to get that across before.

I check for add-on updates manually already. I have all automatic updating turned off. Checking for updates does not fix the problem. I have no "button at the bottom of the Extension Manager window," that may be a Windows/Mac thing. The button for updating add-ons on Linux is at the top. It has a drop-down menu with various options, I assume that's what you mean?

This is a fresh profile. I'm using Linux. Done the profile business several times.

It turns out that the add-on manager will work correctly if I change the data in install.rdf to reflect the correct version, although it still seems to choke up, that is, slow down considerably, when I have over 30 add-ons installed. I have had to restart to get it to load twice, but at least it still loads. I have 37 enabled / 2 disabled right now. This is more than usual due to my experimenting, but thus far my theory is holding true.

If the version # in the install.rdf is correct the add-on manager works as it should.

If I disable add-on compatibility checking and install add-ons that are marked as NOT compatible from AMO the add-on manager works as it should.

If I install an extension marked as compatible on AMO but has the wrong version # in the install.rdf the add-on manager freezes, crippling the browser. This happens every time. Whatever Firefox is supposed to be doing with extensions.sqlite is failing.

Here are some of the offending add-ons that crash the add-on manager unless I manually change the install.rdf version #:

Download Statusbar, Friendly Bug, Firecookie, BBCodeExtra, Memory Restart, Omnibar, Stylish Custom, Yexplore

All those add-ons work fine when installed from AMO, but crash the add-on manager. If I change the install.rdf file, they no longer trash the manager. I may be missing some things somewhere, I am not a developer, but the causation is clear. I can reproduce this again and again. Seriously, over and over again, on fresh profiles. To reiterate, the underlying issue may be something I don't understand, but this is specifically, without fail, what is happening.

Any insight you may have regarding this issue is more than welcome.

Modified by deadite81

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You may have security software that messes with files in the Firefox Profile Folder, in this case extensions.sqlite and may prevent Firefox from accessing or locking the database.

the-edmeister
  • Top 10 Contributor
  • Moderator
3194 solutions 24384 answers

"... but I have to reiterate that all 23 of the add-ons that don't break the add-on manager have the correct version number or "4.0.*" They are all popular add-ons that are updated regularly, so if you choose to "doubt" that's up to you :)"

Popular or not, extensions don't necessarily carry the exact maxVersion information in their own respective install.rdf file. Firefox is dependent upon getting compatibility information from the AMO server for the extensions.sqlite file, so it can determine if an extension is "compatible" or not.

This is the maxVersion information in some of your extensions that I just downloaded from AMO and inspected the install.rdf file for maxVersion information, for Firefox which is em:ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}

Download Statusbar = 4.08pre
Friendly Bug = 4.0b8pre
Firecookie = 4.0b8pre
BBCodeXtra = 3.7a5pre
Memory Restart = 4.0b6
Omnibar = 4.0b9pre
Stylish-Custom = 4.0b9pre
yExplore = 3.7a1pre

Are you saying that the maxVersion in the install.rdf files for each of those extensions says 4.0.* ??


I think the next step would for you to look into what cor-el mentioned - something messing with the extensions.sqlite file and possibly keeping it from being updated properly.

Question owner

Thanks, but I don't think so. I'm not running any anti-virus software. I use Transmission bittorrent client, but the blocklist is managed from inside it (as opposed to using Moblock). My firewall is at the router level. So I don't have any security software running at all. I also disable Firefox's internal malware protection.

I took a peak in the extension.sqlite file, but unfortunately it didn't make much sense to me. I located the table with the max/min version numbers, but all the extension id's were literally identical. I deleted it so Firefox would be forced to rebuild it, but it looked the same. I'm using the SQL Manager extension to view extensions.sqlite.

The add-on manager is still working, but not reliably. If I have Firefox open for a while and try to open it it refuses to display my add-ons. But if I restart it works fine, whereas before it simply wouldn't work at all, no matter what I did. To me this is an indication that something becomes corrupted over time, but I am not doing anything out of the ordinary, so I guess I can only hope that it randomly gets fixed by an update :(

Question owner

I'm sorry the-edmeister, but you have misread my post. Those are the extensions I specifically mention as having the incorrect version number. The 23 add-ons with the correct version numbers DO NOT include those problem add-ons, hence my conclusions. I checked every one by hand. Please reread my posts, if you find err let me know, but I explained all this already. I posted here for help, not to argue.

I am running Linux and not using any security software, however I do agree that something must be corrupting the extensions.sqlite file.

the-edmeister
  • Top 10 Contributor
  • Moderator
3194 solutions 24384 answers

Sorry that I misread some of what you posted.

The easiest "fix" seems to be to edit the maxVersion information in all the extensions that are causing problems for you to 4.0.* before you install those extensions in Firefox, so that Firefox doesn't have to figure the "compatibility" out for its' self.

Question owner

You are correct. At least for now I must check all add-ons before installing for the correct version number. I'm sure it will be fixed soon....

nomad2 0 solutions 3 answers

I'm having the same thing happen. Firefox 4 addon manager freezes when I click the extensions tab. These are very popular and well updated addons and I have to disable them because the addon manager will freeze.

I experimented in single mode, disabled and enabled extensions, there doesn't appear to be any consistently or logic, some times an added extension will freeze and the same extension next restart it will not freeze. This tells me it's not the extension, it's Firefox.

Re: changing the install.rdf file many extensions do not have this, they are a single file only and the content is all gibberish and unreadable, think its encrypted.

Perhaps there needs to be a way to access extension preferences without ever needing to go to addon manager. At least this way we can install our addons and use them.

I'm thinking of downgrading to 3.6 because 4.0 freezing isn't going to cut it.

the-edmeister
  • Top 10 Contributor
  • Moderator
3194 solutions 24384 answers

3.6.16 is available here:
http://www.mozilla.com/en-US/firefox/all-older.html

nomad2 0 solutions 3 answers

Holy granola ride batman, think I fixed it. Not sure how it happen but last I remember I deleted old things in the mozilla folders anywhere I could find them. Look in the library both hd/library and user/library. I double checked by adding extensions and clicking on the tab in the add-on manager, all good to go.

Modified by nomad2

Question owner

I think I have solved the problem (for real this time. I stopped posting here because it was going nowhere). It appears that Firefox uses some kind of new "aggressive caching" mechanism, which I now am repeatedly able to demonstrate on two Linux boxes is the problem. You can read about the new way of caching things here: http://blog.mozilla.com/addons/2010/11/11/making-add-on-compatible-firefox-4/

If I run Firefox with the option "--purgecaches" I am then able to use the Add-on Manager correctly, at least for that one time. AFAIK it could be any number of add-ons causing this breakage, because as you can see from my other posts I have done much experimenting. I have waited a few days to post this too see if my assumption was correct and it appears it is. In fact I just did it; the Add-on Manager froze, I closed Firefox and then opened it again with "--purgecaches" and was again able to access it. It has frozen multiple times in just the past few days, and running "firefox --purgecaches" on the command line fixed it every time. This may explain why running certain operations with Bleachbit fixed the issue sometimes, although I can't say I understand why.

So my take is that the "aggressive caching" is too aggressive! Either add-ons are not properly implementing it or the code is buggy. Every one of my add-ons is approved by and downloaded from Mozilla, so this failure is inexcusable. Anyway, purging the cache doesn't fix the problem permanently, but appears to be the source of the problem. As far as I can tell purging the cache has no adverse effects, it just makes the Add-on Manager work, at least for the current session.

Please do let me know if any of you guys learn anything else about this!

drake01 0 solutions 1 answers

It happened to me twice. I installed an addon and next time trying to open the addon manager and it freezes the browser. A solution for this problem if an addon recently installed caused it:

IF ((you remember what addons you recently added just before the problem started) || ( the specific addon which you added and the problem started) && (you are using Linux)) { 1. Find the folder called .mozilla in home folder (You can activate visibility of hidden dotted folder by using ctrl+h in nautilus file manager) 2. Press ctrl+F and search for install.rdf. You will get a number of files depending upon the no. of addons installed. 3. Open each of them using a text editor and look for the name of the addon they belong to. If you find it to be of "suspected addon", find the folder that file is contained in. Remove that folder or folders and move them to some safe place say your desktop. Sometimes you will not be able to find the install.rdf file for the addon which you suspect strongly to be the culprit. Most probably the addon is archived n stored in ~/.mozilla/firefox/'somename'.default/extensions/ Look for the name of that addon in this folder. If you find it remove it too to safe folder. 4. After removing all suspected folders, try opening addon manager. If you are able to do it successfully, leave a comment thanking me. }

One advice: Never install an addon marked as experimental on firefox addon website!!!

Aleksej 3 solutions 28 answers

Chosen Solution

Possibly https://bugzilla.mozilla.org/show_bug.cgi?id=637286