X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox amnesia - login/session cookies don't remain after restart

Posted

This is driving me nuts having to log back in to every site every time I close FF. I also lose 'preferences' like turning off Google instant/safesurf (resets to on/moderate every time). I have tried clearing all private data then closing FF then deleting the cookies.sqlite file, and it is still happening. Anyone have any other suggestions?

Additional System Details

This happened

Every time Firefox opened

This started when...

earlier this week, all of a sudden. Installation is only a couple weeks old.

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.51204.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

Application Basics
Name
Firefox
Version
4.0b10
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Add-on Compatibility Reporter
0.7
true
compatibility@addons.mozilla.org
CA Toolbar
1.2.1.24
true
{e9259cba-e7ad-4f74-863f-ef9fe935394d}
CA Link Advisor
1.2.1.24
true
{8b02914c-4e6b-4410-90e1-1a2b1b69b12d}
Feedback
1.0.4
true
testpilot@labs.mozilla.com
DownloadHelper
4.8.2
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110121161358
browser.startup.homepage_override.mstone
rv:2.0b10
extensions.checkCompatibility
false
extensions.checkCompatibility.3.6
false
extensions.checkCompatibility.3.6b
false
extensions.checkCompatibility.3.6p
false
extensions.checkCompatibility.3.6pre
false
extensions.checkCompatibility.3.7a
false
extensions.checkCompatibility.4.0b
false
extensions.checkCompatibility.4.0p
false
extensions.checkCompatibility.4.0pre
false
extensions.lastAppVersion
4.0b10
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
249593
print.print_printer
Microsoft XPS Document Writer
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_page_delay
50
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11.00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8.50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1.00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon 3100 Graphics
Vendor ID
1002
Device ID
9613
Adapter RAM
256
Adapter Drivers
atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.632.1.2000
Driver Date
8-17-2009
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.16699)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers
  • Such details are stored in a cookie.
  • You need an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep that cookie, especially for secure websites and if you let cookies expire when Firefox closes
  • Make sure that you do not use Remove recent browsing, search and download history to clear the "Cookies" and the "Site Preferences"

Clearing "Site Preferences" clears all cookies, images, pop-up windows, software installation, and password exceptions.

Question owner

I know this is cookie related - I followed the suggested procedure of clearing all private data then deleting the 'cookies.sqlite' file, but it did not work. This problem started suddenly. I did not change anything or add any extensions right before it started. The history/private data is NOT set to clear on exit. I have never had to manually set a cookie exception for any site before, all I had to do is click the "Remember Me" box upon logging in. Now all of a sudden it is not saving any cookies at all upon exit, and every time I open Firefox I have to log back in to all my sites and reset my preferences. This is a FF bug, not user error.

Modified by Taz420

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete cookies.sqlite-journal and cookies.txt, if they exist, in the Profile Folder in case the file cookies.sqlite got corrupted.


  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"

Modified by cor-el

Question owner

No offense, but are you even reading what I type? I said in both posts I already tried deleting the cookies.sqlite file. And yes, I closed FF before I deleted it. The other two files you mention do not exist. I also already said that it is set to REMEMBER cookies and history.

I don't mean to be rude, but I don't want "Dell customer service" style scripted flowchart answers, I want a solution to the problem. Please read my post (not just the subject) before answering.

Modified by Taz420

Question owner

Ok, now this just started happening on a second computer. Again, it started out of the blue, nothing had been changed, installed, or updated. Deleting the 'cookies.sqlite' file does nothing. Does anyone know why this is happening?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Helpful Reply

Is there any cleanup software like CCleaner installed on those computers?

Question owner

Nope. Only CA Antivirus. Both computers are relatively 'fresh' in their Windows 7 (and therefore Firefox) installations. The one that stared with the problem first (my laptop) is actually the newer installation.

Question owner

Ok, now I'm really getting annoyed with this. I completely uninstalled FF, including all personal data, reinstalled, AND THE PROBLEM REMAINED. WTF? Why is this happening? I have tried running FF as administrator, I have tried adding sites as cookie exceptions, I have tried purging all private data, I have deleted that stupid cookies.sqlite so many times I see it in my sleep.

I HAVE noticed that my two webmail servers DO seem to save their login cookies for some amount of time, because I can close FF, reopen, go to Gmail, and I won't have to log back in. But absolutely nothing else does. And even though Gmail will log me back in automatically, Google search still forgets the settings when I turn Instant and Safesearch off. I have even gone and signed up for random forums just to test it to make sure it wasn't the worlds biggest coincidence that every forum I happen to use has the same exact issue, and I get the same exact problem.

What the HELL is the problem? And I OBVIOUSLY am not the only one having this issue. Google is chock full of people who have to problem and are not getting any useful answers.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Do you still have the cookies from the previous session the next time that you start Firefox?

Question owner

I seem to have found the cause. Even though in the settings, FF is set to NOT clear history and cookies, there is a setting in about:config that conflicts with that.

privacy.clearOnShutdown.cookies default setting is true. Changing it to false solved the problem.

MathewT 0 solutions 1 answers

Helpful Reply

Hi. I had this problem where ending/restarting FF lost all cookie settings. This started happening on multiple sites. I tried reinstalling / deleting cookies files, etc. as suggested above. No help. Discovered that there are a couple of FF Privacy Options that need to be set properly (I had thought that only one was required). Here they are. Go to:

  Firefox/Tools/Options/Privacy/

(1)Tick box beside "Accept Cookies from site"

(1a)"Keep until:" select "they expire"

(2)If "Clear History when Firefox closes" is ticked off, then click "Settings" and untick "Cookies"

Then click "OK" / "OK" Then restart FF. Go to the site(s) you've been having problems with. Sign in, etc., to allow the cookies to be set properly with your site options, etc. Then sign out of the site & restart FF.

Sign back in & you should find that the cookie settings from the previous signon remain in force.

Hope this is helpful

[Btw, I yelled really loud at my bank cause I thought they'd screwed up the site & were corrupting the cookies. Just a bit embarassed -- duh!]