X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

cant print coupons with firefox browser

Posted

trying to print coupons from coupons.com will not let me unless i close firefox browser then i see it in the download window but when i go to open it says i need to close firefox browser and then i am no longer connected

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Adobe PDF Plug-In For Firefox and Netscape
  • Adobe Acrobat Plug-In Version 5.10 for Netscape
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.0 r42
  • 4.0.51204.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_14 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.16) Gecko/20101130 Firefox/3.5.16

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24452 answers

"...it says i need to close firefox browser..."

That sounds like instructions for installing a Plugin for Firefox. You already have two "coupon" Plugins installed for Firefox.

  1. Coupons, Inc. Coupon Printer Plugin
  2. Coupons, Inc. Coupon Printer DLL
ellenw1952 0 solutions 2 answers

I found this on another forum.....

Coupon Printer requires a plugin. When a new version of FF is released, the plugin is more than likely not compatible. The plugin author has to make it compatible in order to work. However, if you install or have installed IE Tab Plus and switch rendering engines, it will work in any version of FF including 4.0+. Also keep in mind that Coupon Printer requires Active-X to run properly, something that "can" be a security risk in Firefox, etc.

Modified by ellenw1952

brian5 0 solutions 2 answers

The EdMeister - This didn't tell me anything with regards to solving this problem. I, also, have these two plug ins but can not print - so what is the solution?

Modified by brian5

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24452 answers

Sorry brian5, I wasn't wasn't answering you 6 month ago, was I?

Why not ask for support from the coupon website or the developer of those plugins?
Add-on developers are responsible for supporting what they create, not Mozilla. "We" try to help users with anything related to Firefox and add-ons when we can, but without signing up for the coupon service I can't even get as far as a download page for those coupon plugins and see what instructions they provide for their users, if any. There is no way for non-users of that service to get the plugins.

You might want to consider trying what ellenw1952 posted about 3 months ago, using IE Tab 2 - https://addons.mozilla.org/en-US/firefox/addon/ie-tab-2-ff-36/ - and opening the coupon pages in an IE tab within Firefox.