X
Tap here to go to the mobile version of the site.

Support Forum

"Quit Firefox" dialog disappear in FF 4.0 beta 10

Posted

Hello. I'm wondering if this happens only to me, the "Quit Firefox" dialog don't show to provide the options of "save and quit"/"quit"/"cancel". I'm sure enabled the option to warn me when closing multiple tabs and opened more than 1 tab when I close Firefox. This only happen in the latest Firefox 4.0 beta 10, actually I discovered this problem in the nighty build of 4.0 b10, and I hope this will fix in the final b10, but it seems not. I've done a clean install b10 on several machines too, but the results are the same. As a result I roll back to 4.0 b9.

Hello. I'm wondering if this happens only to me, the "Quit Firefox" dialog don't show to provide the options of "save and quit"/"quit"/"cancel". I'm sure enabled the option to warn me when closing multiple tabs and opened more than 1 tab when I close Firefox. This only happen in the latest Firefox 4.0 beta 10, actually I discovered this problem in the nighty build of 4.0 b10, and I hope this will fix in the final b10, but it seems not. I've done a clean install b10 on several machines too, but the results are the same. As a result I roll back to 4.0 b9.

Modified by UltimateGTR

Chosen solution

Another easier solution it to use about:config. Type about:config into the browser address bar and press enter, then promise to be careful. Then enter "quit" in the filter box and change "browser.warnOnQuit" to true.

How updating from beta 9 to beta 10 changed this config option from true to false I have no idea but I lost a lot of open tabs with things I have to do (some have been sitting there for weeks and yes I should have done them by now) when it closed without giving me the option to save tabs and quit. I have no hope of retrieving them as I opened them ages ago. I hope this was not someones "good idea".

Another option is under the general tab in the options select show tabs from last time next to what to do when firefox starts. Then it will always save the tabs upon closing.

UPDATE: There is now an option to "restore last session" under history under the firefox button. I read about it in [https://bugzilla.mozilla.org/show_bug.cgi?id=592822] thanks cor-el. Pity I didn't find and read the bug report before closing firefox multiple times.

Read this answer in context 33

Additional System Details

This happened

Every time Firefox opened

This started when...

After upgraded to FF 4.0 b10

Installed Plug-ins

  • Google Update
  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • wpidetector
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

More Information

Application Basics
Name
Firefox
Version
4.0b9
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Facebook Chat History Manager
1.1.5
true
fbchathistory@firechm.com
Flashblock
1.5.14.2
true
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
Live HTTP headers
0.16
true
{8f8fe09b-0bd3-4470-bc1b-8cad42b8203a}
Extended Statusbar
1.5.6
true
{daf44bf7-a45e-4450-979c-91cf07434c3d}
Firefox Sync
1.6.1
true
{340c2bbc-ce74-4362-90b5-7c26312808ef}
IE Tab 2 (FF 3.6+)
2.12.21.1
true
{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}
Add-on Compatibility Reporter
0.7
true
compatibility@addons.mozilla.org
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
IDM CC
7.2.2
true
mozilla_cc@internetdownloadmanager.com
FlashGot
1.2.8
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
Status-4-Evar
2011.01.17.02
true
status4evar@caligonstudios.com
Feedback
1.0.4
true
testpilot@labs.mozilla.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/
browser.startup.homepage_override.buildID
20110110191547
browser.startup.homepage_override.mstone
rv:2.0b9
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
dom.ipc.plugins.enabled
false
dom.ipc.plugins.enabled.npietab2.dll
true
dom.max_chrome_script_run_time
0
extensions.checkCompatibility
false
extensions.checkCompatibility.3.6
false
extensions.checkCompatibility.3.6b
false
extensions.checkCompatibility.3.6p
false
extensions.checkCompatibility.3.6pre
false
extensions.checkCompatibility.3.7a
false
extensions.checkCompatibility.4.0b
false
extensions.checkCompatibility.4.0b.previous
false
extensions.checkCompatibility.4.0p
false
extensions.checkCompatibility.4.0pre
false
extensions.lastAppVersion
4.0b9
gfx.direct2d.disabled
true
keyword.URL
http://www.bing.com/search?FORM=WLETDF&PC=WLEM&q=
layers.accelerate-none
true
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
122195
places.last_vacuum
1285693350
print.print_printer
HP Deskjet D2300 series
print.printer_HP_Deskjet_D2300_series.print_bgcolor
false
print.printer_HP_Deskjet_D2300_series.print_bgimages
false
print.printer_HP_Deskjet_D2300_series.print_command
print.printer_HP_Deskjet_D2300_series.print_downloadfonts
false
print.printer_HP_Deskjet_D2300_series.print_edge_bottom
0
print.printer_HP_Deskjet_D2300_series.print_edge_left
0
print.printer_HP_Deskjet_D2300_series.print_edge_right
0
print.printer_HP_Deskjet_D2300_series.print_edge_top
0
print.printer_HP_Deskjet_D2300_series.print_evenpages
true
print.printer_HP_Deskjet_D2300_series.print_footercenter
print.printer_HP_Deskjet_D2300_series.print_footerleft
&PT
print.printer_HP_Deskjet_D2300_series.print_footerright
&D
print.printer_HP_Deskjet_D2300_series.print_headercenter
print.printer_HP_Deskjet_D2300_series.print_headerleft
&T
print.printer_HP_Deskjet_D2300_series.print_headerright
&U
print.printer_HP_Deskjet_D2300_series.print_in_color
true
print.printer_HP_Deskjet_D2300_series.print_margin_bottom
0.5
print.printer_HP_Deskjet_D2300_series.print_margin_left
0.5
print.printer_HP_Deskjet_D2300_series.print_margin_right
0.5
print.printer_HP_Deskjet_D2300_series.print_margin_top
0.5
print.printer_HP_Deskjet_D2300_series.print_oddpages
true
print.printer_HP_Deskjet_D2300_series.print_orientation
0
print.printer_HP_Deskjet_D2300_series.print_page_delay
50
print.printer_HP_Deskjet_D2300_series.print_paper_data
9
print.printer_HP_Deskjet_D2300_series.print_paper_height
11.00
print.printer_HP_Deskjet_D2300_series.print_paper_size_type
0
print.printer_HP_Deskjet_D2300_series.print_paper_size_unit
1
print.printer_HP_Deskjet_D2300_series.print_paper_width
8.50
print.printer_HP_Deskjet_D2300_series.print_reversed
false
print.printer_HP_Deskjet_D2300_series.print_scaling
1.00
print.printer_HP_Deskjet_D2300_series.print_shrink_to_fit
true
print.printer_HP_Deskjet_D2300_series.print_to_file
false
print.printer_HP_Deskjet_D2300_series.print_unwriteable_margin_bottom
0
print.printer_HP_Deskjet_D2300_series.print_unwriteable_margin_left
0
print.printer_HP_Deskjet_D2300_series.print_unwriteable_margin_right
0
print.printer_HP_Deskjet_D2300_series.print_unwriteable_margin_top
0
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics
Vendor ID
8086
Device ID
0046
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2266
Driver Date
12-16-2010
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 10 2011 19:54:16)
GPU Accelerated Windows
0/1

akash3656 0 solutions 1 answers

Helpful Reply

As a workaround (for save and quit) I use this extension... https://addons.mozilla.org/en-US/firefox/addon/session-manager/

Right click on the back button and click customize.... Search for session manager, click it drag it and drop it beside the feedback button...

Open some tabs... close it the window... Relaunch firefox -> right click on the icon you put beside feedback (session manger) -> Previous sessions -> Previous Browsing Session...

I wish Mozilla team fix this up as I HATE THIS! I want a warning... In fact I hated chrome for not warning me when closing windows with multiple tabs... Rolling back to FF4b9 IS NOT A SOLUTION... I have RAM leaking issues with b9 (with my extensions) which I noticed after installing b10, ram utilization went down...

As a workaround (for save and quit) I use this extension... https://addons.mozilla.org/en-US/firefox/addon/session-manager/ Right click on the back button and click customize.... Search for session manager, click it drag it and drop it beside the feedback button... Open some tabs... close it the window... Relaunch firefox -> right click on the icon you put beside feedback (session manger) -> Previous sessions -> Previous Browsing Session... I wish Mozilla team fix this up as I HATE THIS! I want a warning... In fact I hated chrome for not warning me when closing windows with multiple tabs... Rolling back to FF4b9 IS NOT A SOLUTION... I have RAM leaking issues with b9 (with my extensions) which I noticed after installing b10, ram utilization went down...
shmaun 1 solutions 3 answers

Chosen Solution

Another easier solution it to use about:config. Type about:config into the browser address bar and press enter, then promise to be careful. Then enter "quit" in the filter box and change "browser.warnOnQuit" to true.

How updating from beta 9 to beta 10 changed this config option from true to false I have no idea but I lost a lot of open tabs with things I have to do (some have been sitting there for weeks and yes I should have done them by now) when it closed without giving me the option to save tabs and quit. I have no hope of retrieving them as I opened them ages ago. I hope this was not someones "good idea".

Another option is under the general tab in the options select show tabs from last time next to what to do when firefox starts. Then it will always save the tabs upon closing.

UPDATE: There is now an option to "restore last session" under history under the firefox button. I read about it in [https://bugzilla.mozilla.org/show_bug.cgi?id=592822] thanks cor-el. Pity I didn't find and read the bug report before closing firefox multiple times.

Another easier solution it to use about:config. Type about:config into the browser address bar and press enter, then promise to be careful. Then enter "quit" in the filter box and change "browser.warnOnQuit" to true. How updating from beta 9 to beta 10 changed this config option from true to false I have no idea but I lost a lot of open tabs with things I have to do (some have been sitting there for weeks and yes I should have done them by now) when it closed without giving me the option to save tabs and quit. I have no hope of retrieving them as I opened them ages ago. '''I hope this was not someones "good idea". ''' Another option is under the general tab in the options select show tabs from last time next to what to do when firefox starts. Then it will always save the tabs upon closing. '''UPDATE:''' There is now an option to "restore last session" under history under the firefox button. I read about it in [[https://bugzilla.mozilla.org/show_bug.cgi?id=592822]] thanks cor-el. Pity I didn't find and read the bug report before closing firefox multiple times.

Modified by shmaun

Question owner

Thanks so much akash3656 and shmaun for the help. It's strange they disabled the quit dialog by default in 4.0 b10.

Thanks so much akash3656 and shmaun for the help. It's strange they disabled the quit dialog by default in 4.0 b10.
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

See Bug 592822 – Remove quit warning dialog

(please do not comment in bug reports; you can vote instead)


Always Ask: https://addons.mozilla.org/firefox/addon/always-ask/

See [https://bugzilla.mozilla.org/show_bug.cgi?id=592822 Bug 592822] – Remove quit warning dialog (please do not comment in bug reports; you can vote instead) ---- Always Ask: https://addons.mozilla.org/firefox/addon/always-ask/

Modified by cor-el

shmaun 1 solutions 3 answers

How do I delete this?

How do I delete this?

Modified by shmaun