Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I don't want downloads to automatically save; how do I undo that?


When I want to download a power point it automatically tries to save it and I don't know how to stop it. I DON'T want it to do that. Going to Tools - Options is of no help because I can not unselect the "Save File to" or "Always ask me where to save files".

Additional System Details

Installed Plug-ins

  • IDM FlashPlugin Firefox W32
  • Google Talk Plugin Video Accelerator version:
  • Version
  • Office Plugin for Netscape Navigator
  • Pando Web Installer
  • Adobe PDF Plug-In For Firefox and Netscape
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Google Update
  • Shockwave Flash 10.0 r32
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.51204.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • NBC Direct Firefox Plugin
  • Google Updater pluginhttp://pack.google.com/


  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

See: Tools > Options > General : Downloads : "Always ask me where to save every file"

Question owner

I have done that, but I don't want to tell it where to save because I don't want it to save at all...

janjira 0 solutions 2 answers

Helpful Reply

I got it solved:)

just change the download actions of the types of files that are usually saved "always ask" that would solve the problem of those who accidentally clicked "save file" and "do this from now on" [[download actions| http://support.mozilla.com/en-US/kb/Managing%20file%20types?s=automatic+download&as=s#w_download-actions]]

janjira 0 solutions 2 answers

Helpful Reply

check it out

Modified by janjira