X
Tap here to go to the mobile version of the site.

Support Forum

Cannot download Fallensword Helper Scripts. Getting "Script could not be installed Error: Failed to @require json2.js"

Posted

Hello, I did a drive eraser and reinstalled everything(to clean up computer), then when I got to reinstalling firefox I had a problem. I play a game called Fallensword. It has a script called Fallenswordhelper. So I installed GreaseMonkey, then when I tried to install scripts it said "Script could not be installed Error: Failed to @require json2.js". I have done this to my computer every year since I started using computers. I have never had this before. Please help me get a fix for this, for I google it and cannot find a answer.

Hello, I did a drive eraser and reinstalled everything(to clean up computer), then when I got to reinstalling firefox I had a problem. I play a game called Fallensword. It has a script called Fallenswordhelper. So I installed GreaseMonkey, then when I tried to install scripts it said "Script could not be installed Error: Failed to @require json2.js". I have done this to my computer every year since I started using computers. I have never had this before. Please help me get a fix for this, for I google it and cannot find a answer.

Chosen solution

I'm the original author of FallenSwordHelper. This was due to some change in GreaseMonkey 0.9.0 which made it impossible to have local scripts.

I've made a (temporary?) update so that all extra scripts (such as json2.js) now use absolute URLs.

See also at the official FSH site

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Yesterday

Installed Plug-ins

  • Default Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.10) Gecko/20100504 Firefox/3.5.10 (.NET CLR 3.5.30729)

More Information

George Schizas 1 solutions 2 answers

Chosen Solution

I'm the original author of FallenSwordHelper. This was due to some change in GreaseMonkey 0.9.0 which made it impossible to have local scripts.

I've made a (temporary?) update so that all extra scripts (such as json2.js) now use absolute URLs.

See also at the official FSH site

I'm the original author of FallenSwordHelper. This was due to some change in GreaseMonkey 0.9.0 which made it impossible to have local scripts. I've made a (temporary?) update so that all extra scripts (such as json2.js) now use absolute URLs. See also at the [http://code.google.com/p/fallenswordhelper/issues/detail?id=1108 official FSH site]

Question owner

Thank you for your quick response. When I was a lower level in the game I almost thought it took the fun out of it,,then now that im raising in levels and have 23000+ stam ,,,,I can't live without it,,:),,it makes everything alot easier. I tried it and it worked now,,,thanks again,,,tugreeb/Danny White

Thank you for your quick response. When I was a lower level in the game I almost thought it took the fun out of it,,then now that im raising in levels and have 23000+ stam ,,,,I can't live without it,,:),,it makes everything alot easier. I tried it and it worked now,,,thanks again,,,tugreeb/Danny White
George Schizas 1 solutions 2 answers

Helpful Reply

This was a indeed a problem in Greasemonkey 0.9.0. It has been resolved in Greasemonkey 0.9.1, as can bee seen at their site:

This was a indeed a problem in Greasemonkey 0.9.0. It has been resolved in Greasemonkey 0.9.1, as can bee seen at [https://github.com/greasemonkey/greasemonkey/issues/closed#issue/1262 their site]: