X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I install a search engine in Firefox? I have no search engines...no Google, no Yahoo, nothing.

Posted

One day I opened up Firefox, tried to search for something, and the search would not work. I soon realized that I had no search engines installed. They'd all disappeared. I did nothing to make them disappear as far as I know. I've tried to find any search engines to install, but can find only search engine enhancers.

Modified by aizjanika

Additional System Details

This happened

Every time Firefox opened

This started when...

This started while I had Firefox B 8 installed.

Installed Plug-ins

  • Google Update
  • Shockwave Flash 10.1 r85
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.51204.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

More Information

I updated to Firefox b9, but that did not fix the problem. I then uninstalled and reinstalled, but that also did not fix the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10781 solutions 97024 answers

Helpful Reply

You can try to delete search.sqlite and search.json in the Firefox Profile Folder
You can also check the browser.search.* prefs on the about:config page and reset the ones that appear bold (user set).

  1. Left-click the search engines icon on the search bar
  2. Open "Manage Search Engines"
  3. Click "Restore Defaults"

Look here for additional search engines: http://mycroft.mozdev.org/

scoobidiver 12 solutions 286 answers

It is a known issue caused randomly by the Feedback extension.

Disable or remove it to prevent future occurrences of the problem.

Neil Mayhew 0 solutions 1 answers

Thank you! I had been to that dialog before but didn't know there was a "Restore Defaults" button because it wasn't showing. However, when I resized the dialog the button magically appeared, even though there had been no scroll bars or any other indication that the dialog wasn't big enough for its controls.