X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

DivX Web Player is no longer working.

Posted

DivX Plus Web Player HTML 5 [video] is incompatible with Firefox 4.0b8. <=(disable reason) So i can no longer stream my fav movies. Also, when i click play, sometimes my trafic bar goes crazy like it's downloading from the source, but i have no image or sound just like the divx web player is crashed. So please can you help me? The web player worked on FF 3 and on Opera...

Also, Bitdefender Antiphishing Toolbar, Cooliris and some Microsoft Framework stuff are incompatible with Firefox 4.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • DivX Web Player version 2.1.0.900
  • DivX OVS Helper Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

More Information

Application Basics
Name
Firefox
Version
4.0b8
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
United States English Spellchecker
5.0.1
true
en-US@dictionaries.addons.mozilla.org
Dictionnaire français «Moderne»
3.9.2
true
fr-moderne@dictionaries.addons.mozilla.org
Cooliris
1.12.0.36949
false
piclens@cooliris.com
Romanian spelling dictionary
1.10
true
ro-RO@www.archeus.ro
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
WOT
20100908
true
{a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}
Java Quick Starter
1.0
true
jqs@sun.com
BitDefender Antiphishing Toolbar
2.0
false
FFToolbar@bitdefender.com
Feedback
1.0.3
true
testpilot@labs.mozilla.com
DivX Plus Web Player HTML5 <video>
2.1.0.900
false
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
DivX HiQ
2.1.0.900
false
{6904342A-8307-11DF-A508-4AE2DFD72085}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20101214170338
browser.startup.homepage_override.mstone
rv:2.0b8
extensions.lastAppVersion
4.0b8
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729; .NET4.0E)
network.cookie.prefsMigrated
true
network.http.max-persistent-connections-per-server
4
places.history.expiration.transient_current_max_pages
64358
places.last_vacuum
1292065095
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 6800 XT
Vendor ID
10de
Device ID
00c3
Adapter RAM
Unknown
Adapter Drivers
nv4_disp
Driver Version
6.14.12.5896
Driver Date
7-9-2010
Direct2D Enabled
false
DirectWrite Enabled
false
GPU Accelerated Windows
1/1 Direct3D 9

spaghettihead 0 solutions 3 answers

I don't think it's just with Firefox 4.ob8 as I have version 3.6.15 and since upgrading from 3.6.13 (no probs) to 3.6.14 Vidxden videos will not play at all. I never had any issues with playing Vidxden before but after upgrading to .14 & .15 Firefox hangs and I can't close it down. Vidxden was the best video player for me, no buffering issues, pausing, stopping and starting or not playing at all, like many other players, naturally it was my favourite player to use when watching videos. Thanks to the recent updates I can't use it at all. I haven't been able to get one single video to play that doesn't hang Firefox immediately. I have followed all the troubleshooting suggestions and checked my plugins which are all updated. I have sent messages and posted in the community but so far nothing, no response!

x-mplayer won't work either. I'm so annoyed!

Question owner

I found a solution for this problem... Not that much of a solution but still, i can watch my fav movs. If you have the same problem with Divx web player (when you click play FF4 stops responding for a few seconds and then says: Plug in crashed or something something), close the firefox or safely, restart ur PC and reinstall the Divx web player from http://www.divx.com/. It worked for me, i can now stream with FF4. BUT, for reasons unknown, sometimes if i restart the computer/update FF/close FF while it's playing, and try to watch a video, it won't work - The problem returns - so i'll have to reinstall the web player. Divx web player also crashes if i update firefox.

SO, in short:

  1. Close Firefox.exe and plugincontainer.exe OR restart ur PC;
  2. Go to http://www.divx.com/ and reinstall DivX Web Player;
  3. Enjoy ur online vids;
  4. Do not Close FF(during movie session)/update FF => The problem might come back.
  5. Sadly, you might have to do this every-time you want to stream something.

Hope you'll find this helpful! Sebastian.

Modified by Luftwaffe673

pushthenpull69 0 solutions 3 answers

Helpful Reply

This problem must be huge...

IF you just did the ver 4 upgrade a little while ago, stop and use the windows restore utility to restore your computer to a restore point before the ver 4 upgrade.... You will not lose data, and perhaps reverse setting changes that the ver 4 upgrade does that can't be undone... No one has recommended this yet!!

pushthenpull69 0 solutions 3 answers

Helpful Reply

On or around 4/14 I upgraded to FF4. I then discovered that divxweb was Not supported but I figured Divx would update quickly - didn't happen and their site had NO info.

[see pic of my current directory] So on 5/30 I degraded and reinstalled ver 3.6 per install.log On 6/1 I installed ver. 3.6.17 the last update I knew about. Over the next 10 days I upgraded, my add-ins etc., which was recommended but which seemed odd considering the goal was trying to return to a previous set of settings and DLLs etc. that worked. Still Divx over the web does Not work. So I looked over the FF program directory (attached pic) Arranged chronologically, notice that several ver4 files have not been replaced by ver3.6 files. It makes sense that the installer for ver 3.6 would not have a delete file list that included ver4 files not written yet. I checked the removed-files list and the ver4 files were not there nor are they on the uninstall list that FF3.6 uses to uninstall itself.

I believe now that ver4 was faster because it did things differently from 3.6. There are settings and (according to my directory) java processes that were created by ver4 that can't be undone by simply reinstalling an older version. The older ver3.6 installation files were NOT created to "uninstall" the newer ver4!

This also explains why there has been no immediate response yet... How would you reissue older ver3.6.x installation files so they would uninstall ver4?

I tried to use the start/programs/accessories/system tools/system restore utility to reset my environment to before the ver 4 install and it failed. It didn't surprise me since it was two months ago and considering the other "updates" I did since then.. So.. we ALL NEED a FF4 Degrade Conversion Utility that will uninstall ALL of ver4 (without losing anything).

Modified by pushthenpull69

Question owner

The Solution (4 real this time).

I found a solution 4 our problem. It really works, FF never crashed ever since. All you need to do, is to downgrade the Divx web player. If you like the newer versions you can use my first solution (above), but it will eventually crash so you'll have to do all those steps again. OR You can simply install an older version - DivX Web Player (1.4.2 Beta 2), from here - http://www.vidxden.com/n29-browser-crashes-while-trying-to-play-divx-video.html

Or from here http://download.divx.com/divx/webplayer/labs/DivXWebPlayer142Beta2.exe

Don't worry about your current version, it installs over it (replaces it). When you want to play something from th web it might ask you if you want to upgrade the Divx w player... simply click cancel and enjoy ur vids.

This older beta version really works for me! Since then FF never crashed! It's awesome (or I'm awesome 4 finding this :> )!

Question owner

So, no more FF downgrades, no more Divx w player reinstall just to work a day or 2, no more messing with the FF system files, or sys restore or whatever you guys did. DivX Web Player (1.4.2 Beta 2) from here http://download.divx.com/divx/webplayer/labs/DivXWebPlayer142Beta2.exe

It's an older version of the web player but trust me, it works. And it it asks 4 upgrade, click cancel on that.

rstan66 0 solutions 2 answers

I really appreciate the effort, but this does not work with ff 5.0

Firefoxuserforever 0 solutions 3 answers

Thanks a bunch!!!! It worked........ If you don't want it to bug you asking to upgrade just select remind me once a month or something like that... thanks again..

Firefoxuserforever 0 solutions 3 answers

Crap crashed again I'm running 5.0.1 Firefox "it's a no go on the older version" :(

Hasan 477 solutions 5600 answers

Troubleshooting extensions and themes

Check and tell if its working.

wuotan 1 solutions 4 answers

I have been unable to get any video to play gorrillavid putlocker etc. everything quit... they work on google and explorer... I had not updated firefox because cooliris is my favorite and didn't want to loose it... now i have updated trying to fix video proplem, and problem persists NO VIDEO and now no cooliris either. damn

Such a large video problem, and the other browsers work.... how could firefox fail here?

Modified by wuotan

Chris Ilias
  • Moderator
115 solutions 1064 answers

Hi wuotan,
You're replying to a thread that is over a year old. You should use https://support.mozilla.org/en-US/questions/new where volunteers can get more details about your setup.

Because this thread is so old and more people might start using it for their own questions, I'm going to lock it.