Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox persists in opening my homepage as Google.it instead of Google.com & I wish to correct this

  • No replies
  • 3 have this problem
  • 3 views
more options

I connect to the Internet via a Tooway satellite company which has its hub in Italy. I reside in Czech Republic. I have my homepage set as Google.com in both IE8 & Firefox. When I launch IE8 it opens Google.com (English). When I launch Firefox it opens Google.it (Italian) This also results in many pages opening with the ads & options in Italian rather than English. Please help.