Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ctrl-Enter stopped working in the navigation toolbar in 3.6.13

  • 7 replies
  • 208 have this problem
  • 913 views
  • Last reply by DBCooper

more options

Ctrl-Enter has always been a standard feature in the navigation bar (URL / address bar). For example you type only "getfirefox" in the bar then press Ctrl-Enter and it autofills the http://www and the .com and submits the request, so you are taken to http://www.getfirefox.com without having to type anything other than "getfirefox" and Ctrl-Enter.

This stopped working when I updated to 3.6.13. Also I cannot type a full URL and simply press Enter to submit it. The only way I can cause the browser to go to the URL I entered is to manually put the mouse cursor on the "right arrow" icon at the right end of the URL window and click that icon.

As you can imagine, this is really annoying. I disabled all of my addons (I suspected Firebug or Web Developer of causing the problem) and the problem still persisted anyway. I reinstalled Firefox 3.6.13 and the problem is still the same. I wonder if it has anything to do with Firefox 4 beta being installed on my system. But I don't try to use them at the same time.

Chosen solution

I seem to recollect someone recently saying AVG may cause this sort of problem, but you do not mention using that.

Try using Diagnose Firefox issues using Troubleshoot Mode but initially when you get the first screen coming up do not make changes use the continue button. Have a look at

Read this answer in context 👍 12

All Replies (7)

more options

It works ok for me. Why not try example Ctrl Rtn, that as expected goes to the reserved site example.com Getfirefox on my system actually redirects to a site other than getfirefox.com.

I have firebug installed and ff 3.6.13 with 4.0Beta8 also, but I do not use Web Developer.

■ Have you looked at

more options

doesn't work at example.com or any url whatsoever.

The problem is more than I originally reported. When I start typing a URL that I commonly use, the autocomplete list pops up and I can scroll to a choice in the autocomplete list and either click on it, or hit Enter on it. Either of those actions used to cause the browser to open the URL I chose. Now neither one works. My choice from the autocomplete list does replace what I was previously typing in the address bar as it should, but the browser does not act on the choice until I manually click the right arrow icon.

more options

Chosen Solution

I seem to recollect someone recently saying AVG may cause this sort of problem, but you do not mention using that.

Try using Diagnose Firefox issues using Troubleshoot Mode but initially when you get the first screen coming up do not make changes use the continue button. Have a look at

more options

Thanks for jogging my brain, John99.

It turned out to be an addon installed by AVG, "AVG Safe Search". Its function is to warn you before you click a malicious link. It has always worked fine with no side effects before, but a recent update of it must have caused this problem. When I disable it Enter and Ctrl-Enter work properly in the address bar.

Happy new year.

more options

Glad it worked, Happy New Year

more options

Same here. The culprit was AVG. Thanks!

more options

I knew AVG Safe Search couldn't be the problem because I had uninstalled it! Guess what. It was uninstalled, all right, but the add-on to Firefox was still there, disabled. That uninstall was grayed out.

I re-enabled it and disabled it, this time it said it would be uninstalled the next time I restarted Firefox. So I did that. Nothing changed. However, this time I noticed that just above the restart message was a place to click restart. That restart worked!

Some people just know how to write obtuse software messages.

Modified by DBCooper