X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The new Java Plug-in requires a recent version of the Firefox browser

Posted

I installed Firefox 3.6.13 but a pop-up error message reads "The new Java Plug-in requires a recent version of the Firefox browser (version 3 or later)" comes out whenever I run an English dictionary program. It is quite annoying although the program can be processed if I ignore the warning. Could you help me to fix it. Thanks.

Additional System Details

This happened

Not sure how often

This started when...

I try to run an Englilsh dictionary program which has pictures and sound files

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Default Plug-in
  • Shockwave Flash 9.0 r115
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.51204.0
  • NPWLPG
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; zh-TW; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

I guess that Maybe the settings in Firefox should be adjusted and required by Java Plug-in

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Your More system details list shows that you have the "Next Generation Java Plug-in 1.6.0_22", so that should be OK.
Does Java work on the test pages?


There are other things that need attention:
Your above posted system details show outdated plugin(s) with known security and stability risks that you should update.

  • Shockwave Flash 9.0 r115

Update the Flash plugin to the latest version.

DavidLNWong 0 solutions 1 answers

Helpful Reply

If the dictionary program you are using is "Longman Dictionary of Contemporary English (Updated edition)" , I believe you will find the soluation on the following website:

http://pearsonsupport.helpserve.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=301

idinesh 0 solutions 1 answers

The above solution given above by DavidLNWong is also working for "Oxford Advanced Learner's Dictionary - 7th edition" however the path on your pc would be "C:\Program Files\Oxford\OALD7\defaults\pref".

ehsanbomb 0 solutions 3 answers

I can't reach the URL, could you please correct it. and by the way, I found the link above by googling it but I couldn't download the patch, do you have the patch? if so, be a sport and upload it somewhere else. I'll be thankful if anyone could do that for everyone's having this problem

Modified by ehsanbomb

ChaseWang 0 solutions 1 answers

Helpful Reply

The URL is dead but you can find it here: http://pearsonsupport.helpserve.com/Knowledgebase/Comments/Submit/240/ The patch file link does not work as well. But I manage to solve the problem on my PC by following these steps:

Open Windows Explorer and browse to the dictionary installation directory (typically C:\Program Files\Longman\ldoce4v2). Browse into the "defaults" folder, then the "prefs" folder. Rename the file "winpref.js" to "winpref.js.old".

Hopefully it helps.

Modified by ChaseWang

ehsanbomb 0 solutions 3 answers

thanks a lot,pal it did the trick

awj141 0 solutions 1 answers

In fact, the only thing to do is modify the winpref.js (open it by notepad), and find the following line:

// Locate plugins by the directories specified in the Windows registry for PLIDs

// Which is currently HKLM\Software\MozillaPlugins\xxxPLIDxxx\Path

pref("plugin.scan.plid.all", true);

command the last line by plus "//" at the head of the line:


// Locate plugins by the directories specified in the Windows registry for PLIDs

// Which is currently HKLM\Software\MozillaPlugins\xxxPLIDxxx\Path

//pref("plugin.scan.plid.all", true);

and save it. Now re-open the Longman, it works!!

Modified by awj141

jbenemo 0 solutions 1 answers

About the sugestion by awj141: This really resolved my problem.

Only substitute this: pref("plugin.scan.plid.all", true);

For this: //pref("plugin.scan.plid.all", true);

Only put two simbols (//) at the head of the line.

Cool! Thnaks!

Modified by jbenemo

phantrapro 0 solutions 1 answers

great thank pal.i try to find all the way.but the NOTE patch file which noted tobe download is rather quite dim.that makes rather to see its notice. you need to make it outline and clearer.anyway.gracias.merci boucoup!!!!!