Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My home page goes to http://www.flyingincognitosleep.com/cgi-bin/h.pl, and I cannot change the setting. Advice?

  • 14 replies
  • 306 have this problem
  • 650 views
  • Last reply by levi501

more options

When I try to change the setting, it goes back to this page.

And the page is not a valid address.

All Replies (14)

more options

There are a couple of things to check, for details see the How to fix preferences that won't save article.

more options

I ran through these steps, with no success

any other thoughts.

more options

OK for all contributors I am attaching the chat log from this chat Livechat Log

more options

Please let me know when you post a solution

more options

Have you been able to get that - user_pref("browser.startup.homepage", "http://flyingincognitosleep.com/cgi-bin/h.pl"); - removed from the user.js file?

If not, have you tried deleting that user.js file altogether?
Firefox doesn't need that file to work, it's an optional file that's allows prefs to be added to Firefox a little easier than creating an addon, or to help with mass rollouts of prefs for corporate sys admins.

If that pref keeps reappearing after it is deleted from the user.js file, or that entire user.js file keeps coming back after you delete it, you have some Malware on your PC that need need to find and remove.

more options

Do a malware check with some malware scan programs.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of the database before doing a scan.

See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and What to do when searches take you to the wrong search website

If you can't fix it with the above listed scanners then you need to ask advise on one of the forums that specialize in malware removal mentioned in the Popups_not_blocked article.

more options

I came down with this yesterday. It took 8 hours and 3-4 recommended malware/antivirus programs, some in safe mode with follow-ups in regular mode to get rid of the "security shield" malware/virus that apparently goes along with it. All my time and work did not get rid of the browser hijack to "flyingincognitosleep.com." This stuff is apparently still very new, so the help I found online was in large part above my head. What I did find, and just finished doing that worked to get rid of the hijacking, was re-installed another browser I had previously uninstalled, uninstall Firefox (including personal settings, etc., when that screen "check box" comes up), then downloaded and imported my settings from the other browser. I realize this may not be helpful to others unless they have my particular situation (another browser, complete with favorites, but uninstalled, on my machine), but I wanted to offer it up in case others are able to use the info.

more options

Two items above do not work

more options

Same here from the same source - SecurityShield. I finally found -after a lot more than 8 hours - that "Hit Man 3" -which you can download at CNET - is the only program that eliminates the Windows IE , updates, and Defender problems - but I still have the flyingincognitosleep redirect on my firefox browser. Hope someone figures this out...

more options

Ok, I think I finally got rid of it.

Firstly, I'm running 32 bit Vista Home Premium SP2, so that's all I can say for sure this works for, but I'd give it a go on another OS if need be.

Go to http://www.safer-networking.org/en/download/index.html and download Spybot S&D, install it then update it.

Next, go to http://www.surfright.nl/en/downloads/ and get Hitman Pro 3.5.

1. Run Hitman, fix whatever problems it finds.

2. Restart in safe mode and run Spybot S&D. It should come up with 2 malware detections and one security detection. There could be more if you're infected with something else and don't know it, I'm just assuming this is the only thing you have.

3. Restart in Safe Mode with Networking. Run Hitman again, this time it should come up with nothing.

4. Restart as normal and reset your homepage in the options menu. Close out of FF and restart it, you should start back up at the homepage you just set.

Hope this helps.

Modified by Magnivea

more options

I'm running XP Pro SP3. After Magnivea's (above) steps, I then deleted the user.js file as outlined by the-edmeis... 's post. I had searched for this file earlier but couldn't find it - on my computer it's at C:\Documents and Settings\'Your User Name'\Mozilla\Firefox\Profiles\89k62al9.default. The 89k62al9 number probably is different for each user, I don't know. Any way, after changing the home page address on the Tools-Options menu item - the flyingincognitosleep redirect has not reared its ugly head in the last hour. As usual, your mileage may vary.

Modified by bobbygee

more options

Easy fix... Find your "User.JS" file, rename to "User.JS.bak". Rather then go through all the paces you can find it with either SEARCH with older versions of Windows making sure to search all files, hidden too. Open the "Containing Folder" to fix it. Reset your homepage to whatever you want and it's done.

more options

After messing about with this for a while I decided to go back to the basics. Look at what services were running and see if there was anything that I did not recognize.

Bingo! An entry called 'Fepy.exe' running out of the directory: C:\documents and settings\*your user Name*\application data\vaows\fepy.exe

The file is dated 24 Jan, 2011 and the directory was dated 23 March, 2011. The time stamp was about when I started having troubles. I renamed the file and moved the directory. Then I searched the drive and deleted all the instances of this file. Rebooted and clean. Problem gone.

more options

To rid yourself of this problem, all you need to do is rename the file User.js located in C:\Users\Your Username\AppData\Roaming\Mozilla\Firefox\Profiles\edbhcl86.default <---This last folder will be different for everyone Once you get to this location, just rename User.js to User.js.bak Next, you want to goto Tools|Options|General and change your home page and click OK. Now to test the results by click the home button in firefox to see if its your home page you selected.

This solution is for people running Windows 7. I must give credit to bobbygee for the original solution but missing the Roaming directory in his solution.