Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't add search engines?

more options

My search bar has never worked. Not when I had Firefox 3... and not now. I had to add a google toobar, in order to be able to search. This made Firefox very wide and ugly looking. I didn't like it and so I don't want to add it again, now that I have Firefox 4. Please help! I go to add search engines, but they just don't appear when I add them. Why is this?

Chosen solution

First, use a specific profile for Firefox 4.0b7 and keep your current profile for Firefox 3.6. It will solve your ugly look and search engine issue for Firefox 4.0b7.

For your search engine issue in 3.6, close Firefox, rename search.sqlite file and searchplugins folder in your default profile folder, then restart Firefox.

Read this answer in context 👍 2

All Replies (4)

more options

Chosen Solution

First, use a specific profile for Firefox 4.0b7 and keep your current profile for Firefox 3.6. It will solve your ugly look and search engine issue for Firefox 4.0b7.

For your search engine issue in 3.6, close Firefox, rename search.sqlite file and searchplugins folder in your default profile folder, then restart Firefox.

more options

It worked. I'm so happy. Thank you scoobidiver! :)

more options

Didn't work here. I have the following:

User Agent Mozilla/5.0 (X11; Linux x86_64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2. The Linux distro is Ubuntu Natty Narwhal.

The problem is: when I click on "Add to Firefox" I get a popup with the following error message (translated from Portuguese, the English version may not be exactly as quoted below):

"Firefox could not receive the search engine from: https://addons.mozilla.org/firefox/downloads/latest/4609/addon-4609-latest.xml?src=dp-btn-primary"

I tried other search engines, like the official Bing extension, with identical results. Tried to delete de search.sqlite and rename the searchplugins folders, also to no avail.

more options

I found an easy solution. Go to the website you want and right-click on the search bar text area and select "Add a keyword to this search". This will bring up what looks like an "add bookmark" window but in fact will add your chosen search engine to the list.