X
Tap here to go to the mobile version of the site.

Support Forum

How do I fix the right-click context menu; it has blank entries and shows no selectable options?

Posted

recently I have noticed that my right-click context menu looks like it has no entries. It shows up on a right-click, but the whole menu is blank. On further investigation there are scroll buttons on the top and bottom of the menu and if I hover over the up buttom eventually the normal context commands scroll down from above. I noticed this first a few days ago, shortly after the download of 3.6.13. Today I also noticed that some of my menu bars were showing a similar issue with blank entries in the menus. In one case the menu also didn't register where the mouse was, highlighting a command several steps further up.

Is this something to do with the new Mozilla or something else? I only run a couple of addons, Ad Block Plus and Tab Mix Plus. Can try to capture a screen shot of the issue, but difficult since the menu dissapears when I try to do a screen grab!

All help is much appreciated.

recently I have noticed that my right-click context menu looks like it has no entries. It shows up on a right-click, but the whole menu is blank. On further investigation there are scroll buttons on the top and bottom of the menu and if I hover over the up buttom eventually the normal context commands scroll down from above. I noticed this first a few days ago, shortly after the download of 3.6.13. Today I also noticed that some of my menu bars were showing a similar issue with blank entries in the menus. In one case the menu also didn't register where the mouse was, highlighting a command several steps further up. Is this something to do with the new Mozilla or something else? I only run a couple of addons, Ad Block Plus and Tab Mix Plus. Can try to capture a screen shot of the issue, but difficult since the menu dissapears when I try to do a screen grab! All help is much appreciated.

Additional System Details

This happened

Every time Firefox opened

This started when...

Approximately Wednesday 15 December

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • Default Plug-in
  • Shockwave Flash 10.1 r102
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

Application Basics
Name
Firefox
Version
3.6.13
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
1.3.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Tab Mix Plus
0.3.8.4
true
{dc572301-7619-498c-a57d-39143191b318}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
5
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.co.nz
browser.startup.homepage_override.mstone
rv:1.9.2.13
browser.tabs.closeWindowWithLastTab
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
3.6.13
network.cookie.prefsMigrated
true
places.last_vacuum
1292395715
privacy.cpd.extensions-tabmix
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false

the-edmeister
  • Top 10 Contributor
  • Moderator
4082 solutions 30851 answers

Do you have that problem when running in the Firefox SafeMode?
http://support.mozilla.com/en-US/kb/Safe+Mode
Don't select anything right now, just use "Continue in SafeMode."

If not, see this:
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+theme...

Do you have that problem when running in the Firefox SafeMode? <br /> [http://support.mozilla.com/en-US/kb/Safe+Mode] <br /> ''Don't select anything right now, just use "Continue in SafeMode."'' If not, see this: <br /> [http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes]

Question owner

Hi, thanks for the quick response!

While trying to find info on how to fix this I looked up some context menu addons for FF and tried one. It didn't work so I uninstalled it and after that everything was back to normal. Odd, but there you have it. I still don't know what went wrong in the first place but for the moment it appears to have cleared up.

Next time though I will try loading into Safe Mode if I find any issues (I forgot there was one!).

Thanks for getting back to me again.

GC

Hi, thanks for the quick response! While trying to find info on how to fix this I looked up some context menu addons for FF and tried one. It didn't work so I uninstalled it and after that everything was back to normal. Odd, but there you have it. I still don't know what went wrong in the first place but for the moment it appears to have cleared up. Next time though I will try loading into Safe Mode if I find any issues (I forgot there was one!). Thanks for getting back to me again. GC
cor-el
  • Top 10 Contributor
  • Moderator
12919 solutions 118477 answers

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

See also Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears. * Use "Disable all add-ons" on the [[Safe mode]] start window to disable all extensions. * Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") See also [[Troubleshooting extensions and themes]]

Modified by cor-el

milldogtjm 0 solutions 1 answers

This may help go to your start menu find the Firefox safe mode link, click on it a pop up should come up with options on it, select reset toolbars and controls only. this should give you most of the context menu back but i still have a few empty ones, but 95% of the menu is back.

This may help go to your start menu find the Firefox safe mode link, click on it a pop up should come up with options on it, select reset toolbars and controls only. this should give you most of the context menu back but i still have a few empty ones, but 95% of the menu is back.
the orphanage 0 solutions 1 answers

i had a similar problem and the solution seems to be the add-on https everywhere. after disabling https everywhere my context menu works fine. maybe it was conflicting with another add-on i have?

i had a similar problem and the solution seems to be the add-on https everywhere. after disabling https everywhere my context menu works fine. maybe it was conflicting with another add-on i have?