Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot install any add on. Download error -228

  • 5 replies
  • 143 have this problem
  • 1 view
  • Last reply by Mystery100

more options

When I try to install an Add-On, I get the following message:

Firefox could not install the file at

_____________________________

because: Download error -228

This happens with ANY Add-On download. Theme or Add-On.

All Replies (5)

more options

Modified by TonyE

more options

@TonyE

I've visited those links before, but neither of them help, my cache is 50MB, (as I have not messed with the default setting). Halp?

more options

See if this works. Try downloading the .xpi file for the add-on, to do that right-click on the installation link and choose "Save link as". Then in the Firefox menus choose "File > Open File" and open the .xpi file that you downloaded. That should install the add-on.

more options

Well I can now download some addons, but the ones I cannot, I try this fix above and when I choose File > Open, it says invalid/corrupt addon.

more options

Well I can now download some addons, but the ones I cannot, I try this fix above and when I choose File > Open, it says invalid/corrupt addon.