Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have previously not saved passwords how do I change the setting to now save them?

  • 6 replies
  • 73 have this problem
  • 6 views
  • Last reply by TedinOz

more options

I have not used the password saving function in Firefox - choosing not to save them. I want to change this so all my passwords are now saved. I can't find any clues or any information to allow me to do this. Should I delete everything and start again?

Chris.

Chosen solution

All Replies (6)

more options

Chosen Solution

For details on using this feature see the Password Manager - Remember, delete and edit logins and passwords in Firefox article.

more options

Hi Tony,

Have read article several times. Can't work out how I know if a site has barred password saving? Also checked exceptions list - nothing recorded. Sites I have previously not saved passwords for still will not let me save them now. Is the exceptions list the only was this can be reset?

Sorry to be a bit of a dummy.

Chris.

more options

Did you make sure that you haven't set exceptions for those websites?

Tools > Options > Security: Passwords: Exceptions


Also make sure that you not run Firefox in (permanent) Private Browsing - Use Firefox without saving history mode

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"

See also http://kb.mozillazine.org/User_name_and_password_not_remembered

more options

Private browsing always =off.

Use of bookmarlet interesting have loaded it and will try.

Thanks, computers a bit hi tech for me but I can fix broken steam engines!

Chris.

more options

Do you have that problem on all sites or only on a specific website?

If the latter is the case then please provide for link. Then we can check the code on that web page.

more options

I had this problem too but I seem to have solved it. I went to the Privacy settings in Firefox Preferences clicked on 'Use Custom settings for history' and discovered that I was configured to 'Automatically start Firefox in private browsing'. I unchecked this preference and restarted Firefox and everything works fine now