X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get rid of plugin check?

Posted

How can I prevent the Plugin Check tab from loading every time I start Fire Fox?

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Default Plug-in
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • Shockwave Flash 10.1 r102
  • 4.0.50917.0
  • Bing Bar
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

See How to set the home page - Firefox supports multiple home pages separated by '|' symbols

See also: Firefox says it's just updated every time it starts - how to fix

mikeclark 3 solutions 35 answers

I uninstalled Viewpoint Media Player, and that helped me. Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled. For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

Since it seems you don't have the "MetaStream 3 Plugin", it may be that some other plugin is causing the plugincheck tab to pop open. Try going to Tools (menu) -> Add-ons -> Plugins (tab). Look through the list of plugins, and see if any of them have a red warning icon next to them. If one of the plugins has a red warning icon, it may be the plugin responsible for triggering the opening of the tab. Try uninstalling that plugin, or updating it to a newer version.

Modified by mikeclark

peter7187 0 solutions 3 answers

Helpful Reply

This problem is a real headache; I've tried all the solutions posted on [https://support.mozilla.org/en-US/que.../833109] to no avail. Altering the about:config settings such as the ones mentioned in the posts don't work, e.g. setting the plugins.update.url blank only causes the plugin-search website to be substituted with a blank page. I completely removed Firefox and found that after a fresh install the issue would reemerge, not initially, but after opening it after a few times. Also, disabling all plug-ins and add-ons won't help either.

I used to really love Firefox, but don't understand why this problem is yet to be solved properly, as it's been around for some time and has caused many to switch browsers. My faith in the Mozilla team would be restored if this bug were fixed.

P.S. I will never go Chrome (no matter how shiny that poisonous apple is), but there are many other browsers out there...

Modified by peter7187