X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

location bar autocomplete is disabled, don't know how to get it back

Posted

I think I changed a pref or something, but my 'awesome bar' is not so awesome, it doesn't remember anything and I have to type every URL in manually. Please help save my sore hands and wrists from this needless work.

Chosen solution

Make sure that the Location Bar is not set to "Nothing": Tools > Options > Privacy > Location Bar: When using the location bar, suggest: History, Bookmarks, History and Bookmarks
See Smart Location Bar

This can also be a problem with the file places.sqlite that stores the bookmarks and the history.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 071303000006
  • Java 1.3.1 Plug-in
  • DivX Web Player version 1.4.0.233
  • Shockwave Flash 10.1 r85
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.13) Gecko/20101203 YFF35 Firefox/3.6.13

More Information

I've scoured the prefs and checked add-ons (only 2 and they're disabled) and can't find anything that works. Also my history is blank.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96765 answers

Chosen Solution

Make sure that the Location Bar is not set to "Nothing": Tools > Options > Privacy > Location Bar: When using the location bar, suggest: History, Bookmarks, History and Bookmarks
See Smart Location Bar

This can also be a problem with the file places.sqlite that stores the bookmarks and the history.

Question owner

Thank you so much! I had already checked the preference menu for privacy, but that link you included tipped me off to something that worked: I backed up my bookmarks and deleted the "places.sqlite" and "places.sqlite-journal" files, quit firefox, and when I rebooted auto-complete was back in business. My arms and hands thank you!

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96765 answers

You're welcome

kimberama 0 solutions 2 answers

I never, ever had an address or location or awesome bar since downloading Firefox. It don't matter whatcha call it, I ain't got it. Any help would be appreciated, however. Thanks, kimberly