X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why is my right-click disabled to prevent me from selecting "open link to new tab"?

Posted

I don't always want to replace my current window with my new selection of a link address. The right-click menu opens fine in IE. Nothing comes up when I right-click on a link in Firefox.

Additional System Details

This happened

Every time Firefox opened

This started when...

with latest upgrade

Installed Plug-ins

  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Adobe PDF Plug-In For Firefox and Netscape
  • npdnu
  • npdnupdater2
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.1 r102
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)

More Information

Helper7677 165 solutions 1653 answers

Some add-ons (extensions or plugins) can interfere with the right-click context menus

You may need to use Safe Mode to locate the problem: http://support.mozilla.com/en-US/kb/Safe+Mode

  • Firefox Safe Mode is a diagnostic mode that disables Extensions and some other features of Firefox. If you are using a theme, switch to the DEFAULT theme: Tools > Add-ons > Themes before starting Safe Mode. When entering Safe Mode, do not check any items on the entry window, just click "Continue in Safe Mode". Test to see if the problem you are experiencing is corrected.
  • If the problem does not occur in Safe-mode then disable all of your Extensions and Plug-ins and then try to find which is causing it by enabling one at a time until the problem reappears. You MUST close and restart Firefox after EACH change via File > Restart Firefox (on Mac: Firefox > Quit). You can use "Disable all add-ons" on the Safe mode start window.
  • See the following for more information

Other issues that need your attention.

The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post.

  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use the links below to avoid getting the troublesome "getplus" Adobe Download Manager and other "extras" you may not want
      • Use Firefox to download and SAVE the installer to your hard drive from the appropriate link below
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link: ftp://ftp.adobe.com/pub/adobe/reader/
        • Choose your OS
        • Choose the latest #.x version (example 9.x, for version 9)
        • Choose the highest number version listed
          • NOTE: 10.x is the new Adobe Reader X (Windows and Mac only as of this posting)
        • Choose your language
        • Download the file
        • Windows: choose the .exe file; Mac: choose the .dmg file
    • Using either of the links below will force you to install the "getPlus" Adobe Download Manager. Also be sure to uncheck the McAfee Scanner if you do not want the link forcibly installed on your desktop
    • After the installation, start Firefox and check your version again.
cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Helpful Reply

There are also websites that can disable the right-click context menu.

Tools > Options > Content : JavaScript > Advanced > Allow Scripts to:

[ ] "Disable or replace context menus"