Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I would like to be able to run both 4 betas and 3.6 (because of plugins) -how do I do this?

  • 4 replies
  • 31 have this problem
  • 7 views
  • Last reply by cor-el

more options

4 is good, but I need firebug and other plugins which don't work on 4.

How can I run both? (doesn't need to be at the same time)

Chosen solution

One method is to use the portable version of Firefox and use the custom install option to install it on your hard drive. It will automatically create a new profile for the portable version (location where user data is stored). You can get portable Firefox 3.6 from http://portableapps.com/apps/internet/firefox_portable or for Firefox 4 beta from http://portableapps.com/apps/internet/firefox_portable/test

Firebug developers are working on a version that works with Firefox 4, you can get it from http://getfirebug.com/releases/firebug/1.6X/ - install the most recent version listed there.

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

One method is to use the portable version of Firefox and use the custom install option to install it on your hard drive. It will automatically create a new profile for the portable version (location where user data is stored). You can get portable Firefox 3.6 from http://portableapps.com/apps/internet/firefox_portable or for Firefox 4 beta from http://portableapps.com/apps/internet/firefox_portable/test

Firebug developers are working on a version that works with Firefox 4, you can get it from http://getfirebug.com/releases/firebug/1.6X/ - install the most recent version listed there.

more options

... thanks

more options

You're welcome

more options

You can easily create an additional profile folder for the same and other Firefox versions and modify the desktop shortcut to start Firefox with that profile.