X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why I cannot see any picruers on my facebook wall..profile or frienda

Posted

When on Facebook I could see my profile picture along with pictures of friends on my home page . Now no picture shows up at all. But if I use Internet Explorer pictures do show up as they did before.I have not changed any settings for I do not have the ability to do so(not computer smart)

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Shockwave Flash 10.1 r102
  • GEPlugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

With Facebook on display, click on the site identity button (for details on what that is see the How do I tell if my connection to a website is secure? article) and then on More Information. This will open up the page info dialog.

First select the Permissions panel, make sure that "Load Images" is set to allow (selecting Use Default should also work)

Next select the Media panel, then click on the first item in the list. Use the down arrow key to scroll through the list. If any item has the option "Block images from (domain name)" selected, de-select the option.

This should hopefully resolve your issue, but also see Fix problems that cause images to not show.

Some add-ons can also block images, for example if you have AdBlock Plus installed, make sure that you have not accidentally created a filter to block the images.