X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

In Firefox 4 beta 7 and beta 8 pre netflix is not playing but says thaks for installing but says thanks for installing, why?

Posted

Netflix on demand video was playing properly in Firefox 4 beta 6 but no longer works in the later betas. When attempting to play a movie I get a message which says "Thanks for Installing once installation is complete, please restart your browser to watch this movie". I can still watch in Chrome and in Opera (masked as Firefox). Silverlight is up to date and I can see it in the Firefox plugins menu. Does anyone know why or how to fix this? Any answers would be fun thanks!

Chosen solution

Netflix requires the Silverlight plugin, which isn't working in Firefox 4.0 Beta 7 or higher on Mac OS 10.6, because of this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=598406
Bug 598406 - Silverlight not supported by i386/x86_64 universal binary on Mac OS X 10.6

As a temporary workaround until this bug is fixed, try running Firefox 4 Beta in 32-bit mode, using these instructions:

  1. From the menu bar, select Firefox and then select Quit Firefox
  2. Open the Applications folder in Finder and locate the Firefox application icon.
  3. Hold down the control key while you click the Firefox icon and select Get Info from the list of menu items.
  4. In the "Firefox Info" window, click the box in front of "Open in 32-bit mode" so that it is checked.
  5. Close the "Firefox Info" window and then restart Firefox 4.

(The above steps were copied from another article that also suggests running Firefox 4 Beta in 32-bit mode as a workaround for another plugin issue.)

Edited 12-18-2010 to add last step, Close the "Firefox Info" window and then restart Firefox 4. aw

Read this answer in context 31

Additional System Details

Installed Plug-ins

  • Picasa plugin.
  • Watch and download full length videos from your browser
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Browser Plug-In: Plays DivX video in your browser!
  • iPhoto6
  • RealPlayer Plugin
  • Office Live Update v1.0
  • ActiveGS to run Apple IIGS images
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 4.0.50917.0
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101205 Firefox/4.0b8pre

More Information

Netflix plays in other browsers. Silverlight plugin up to date. Worked in Firefox 4 beta 6 but not beta 7 or 8 pre.

millertime0479 0 solutions 1 answers

I have not had an issue with pre 8 and Netflix streaming since it was fixed in late October, and I have had no problem with streaming Netflix with beta 7 at all. I use beta 7 as my primary browser on 2 of the three machines in my home, and none are having issues. What type of system are you using?

Question owner

Thanks I use Mac OS X 10.6 What are you using? Come to think of it I should see how the windows version handles it...

Question owner

The windows 7 version 4 beta 7 does not have this problem for me. I tried uninstalling silverlight in osx and reinstalling, but had no luck.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Chosen Solution

Netflix requires the Silverlight plugin, which isn't working in Firefox 4.0 Beta 7 or higher on Mac OS 10.6, because of this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=598406
Bug 598406 - Silverlight not supported by i386/x86_64 universal binary on Mac OS X 10.6

As a temporary workaround until this bug is fixed, try running Firefox 4 Beta in 32-bit mode, using these instructions:

  1. From the menu bar, select Firefox and then select Quit Firefox
  2. Open the Applications folder in Finder and locate the Firefox application icon.
  3. Hold down the control key while you click the Firefox icon and select Get Info from the list of menu items.
  4. In the "Firefox Info" window, click the box in front of "Open in 32-bit mode" so that it is checked.
  5. Close the "Firefox Info" window and then restart Firefox 4.

(The above steps were copied from another article that also suggests running Firefox 4 Beta in 32-bit mode as a workaround for another plugin issue.)

Edited 12-18-2010 to add last step, Close the "Firefox Info" window and then restart Firefox 4. aw

Modified by AliceWyman

theninthcloud 0 solutions 1 answers

The steps in this post worked for me. (I am running OS 10.6.5, and Firefox 4.0b7)

Thanks for posting this!

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

You're welcome. Thanks for posting that the workaround I posted above worked for you.

Question owner

Thanks! this worked for me also.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

You're welcome, ChauncyPrime. I'm glad the steps in the workaround I posted above worked for you.

(If you can, would you mark that post as the solution?)

keb1306 0 solutions 1 answers

Helpful Reply

I tried using another browser and now have no problem with streaming from Netflix. I know this does not solve the FireFox problem but I'm up for practical solutions.

quackattack2213 0 solutions 1 answers

I have finally found a fix for Mac, and the Netflix issues. No opening in 32 bit, just enable your browsing history to be remembered. I personally use custom settings for history. Also enable a font such as Times, Ariel or Veranda. Besides that no problems for me in days. You cannot be in private browsing mode for Netflix to work.