X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox displaying overlapping text and layout, reset in 'zoom' does nothing.

Posted

Perhaps there is a specific addon, similar to IE 'compatibility view' which will correct layout issues?

Chosen solution

Does that happen only on specific pages or always (more often) ?

If you increased the minimum font size then try a lower setting (default is none) as a too high value can cause issues like you described.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size
  • Tools > Options > Content : Fonts & Colors > Advanced > "Allow pages to choose their own fonts, instead of my selections above"

See also Websites look wrong or appear differently than they should

Read this answer in context 2

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Chosen Solution

Does that happen only on specific pages or always (more often) ?

If you increased the minimum font size then try a lower setting (default is none) as a too high value can cause issues like you described.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size
  • Tools > Options > Content : Fonts & Colors > Advanced > "Allow pages to choose their own fonts, instead of my selections above"

See also Websites look wrong or appear differently than they should

Question owner

Thanks cor-el,

Tried that, but it didn't work. However I think the real problem is column layout.

The page (which I can't post because it's a private login) generally has 3 columns from left to right, but the 2 left columns overlap and the 3rd is situated where the second (middle) column should be.

Any ideas?

whobeit 0 solutions 1 answers

Helpful Reply

Hi,

It sounds like you have the same problem i had for a long time, i think its something to do with the way firefox renders the webpages.

If you open the same site in IE does it display ok?

If it does then the way round it is to use an addon in firefox that displays the webpage as it does in IE.

Try this: http://www.ietab.net/

Let me know if it works.

Modified by whobeit

Question owner

Yes,

IE Tab works!

Once installed you need to go into "Tools", then "IE Tab 2 Options", and add the problem url-

Then apply and reload and it should work.

Thanks for your help- a nice way to avoid getting lost in the source code, etc.

davida 0 solutions 2 answers

I get the same problem using firefox 3.6 on an iMac. Camino or Safari do not have the problem. The site I am having trouble with is the Apple Mac site. Of course IE tabs is not an option for me. Cheers

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Can you post a link to that web page?


Reset the page zoom on websites that look wrong: "View > Zoom > Reset" (Ctrl + 0 (zero)) See http://kb.mozillazine.org/Zoom_text_of_web_pages

If you increased the minimum font size then try the default setting 'none' as a high value can cause issues like you described.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > Minimum Font Size (none)
  • Firefox > Preferences > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

See also Websites look wrong or appear differently than they should

davida 0 solutions 2 answers

Tried all the font and zoom ideas suggested to date but none work. Let's keep trying.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Can you post a link to pages where you see that happen?

It is always possible that there is a problem with the coding of a web page.

guvadafe 0 solutions 5 answers

I have been having this problem for about 3 months or so. Prior to that I don't recall ever seeing web sites with misaligned text. I have tried disabling ALL add-ons etc. to no avail. I can send you a link to my 'personal' family web site to illustrate the problem. I would prefer not to post it publicly. Duane

jedics 0 solutions 2 answers

Ive begun having the same problem in all versions of FF, tried deleting prefs but nothing works. It did happen about the same time I played with my font sizes but tweaking these makes no difference. Really annoying especially with sites like the Tv Guide.

Any answers out there yet?

kat_sea 0 solutions 2 answers

I have this problem when I zoom in on some websites. It enlarges the text but not the image or box so the text ends up overlapping. This doesn't happen with Safari or google chrome (using mac 10.5.8) and I didn't have this problem with Firefox until I upgraded to 5.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Helpful Reply

View > Zoom > [] Zoom Text Only

kat_sea 0 solutions 2 answers

Thank you so much!!!! I tried everything and nothing worked; don't know how I missed this. Thanks again

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

You're welcome