X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I remove the "Open Link in Foreground Tab" command from the left click context menu?

Posted

I use the menumod extension and it has done a perfect job keeping unwanted options from my menus. but when I left click on a link it gives me this unwanted option anyways (i check the options in menumod and there is no checkbox that removes this)

Additional System Details

Installed Plug-ins

The plugins I use are: java deployment kit, java platform se 6 u20, mozilla default plugin, shockwave flash, silverlight, and windows presentation foundation.

The extensions I use are: Java console 6.0.2, menu mod 2.2, microsoft .net framework assistant 1.2.1, noscript 2.0.7, and tab mix plus 0.3.8.4, tab scope 0.3.7

Application

  • User Agent:

More Information

Application Basics
Name
Firefox
Version
3.6.12
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Microsoft .NET Framework Assistant
1.2.1
true
{20a82645-c095-46ed-80e3-08825760534b}
Menu Mod
2.2
true
{8b68fd37-ac54-4c6c-a165-e369ce5ea38e}
Tab Scope
0.3.7
true
tabscope@xuldev.org
Tab Mix Plus
0.3.8.4
true
{dc572301-7619-498c-a57d-39143191b318}
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
NoScript
2.0.7
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.link.open_newwindow
1
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com
browser.startup.homepage_override.mstone
rv:1.9.2.12
browser.tabs.tabMaxWidth
75
browser.tabs.tabMinWidth
70
extensions.lastAppVersion
3.6.12
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729; .NET4.0C)
network.cookie.prefsMigrated
true
privacy.cpd.extensions-tabmix
false
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

You can disable context menu items added by Tab Mix Plus in the options (preferences) of TMP.

nedr 0 solutions 1 answers

What if you don`t have TMP? How do you remove it then?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

"Open Link in Foreground Tab" is not a standard menu item in Firefox, so it must have been added by an extension.

If you want to remove other menu items then look at the Menu Editor extension.