X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Text and font in my FF 4 beta is kind of pixelated, blurred and fuzzily. Why ?

Posted

All other letters and my desktop font is normal! Hmm, i recently reinstalled win7 x64, and maybe something is wrong with that :) But, my display drivers are up to date... I must say that font on most websites are pretty clean (not in Gmail), but their names in tabs and Menu bar is still kind of dimly. The text in the adress bar looks like it is in lower resolution - a little pixelated :)

I have tried to fix it by disabling nvidia 3d vision plugin and microsoft silverlight, but none does the trick...any other suggestions ?

thanks

Modified by thecoa

Chosen solution

Try to set the pref gfx.font_rendering.directwrite.enabled to false on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
See http://kb.mozillazine.org/about%3Aconfig

You can also try to disable: Tools > Options > Advanced : General: Browsing: [ ] "Use hardware acceleration when available"

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • 4.0.50401.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

More Information

Application Basics
Name
Firefox
Version
4.0b7
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
AutocompletePro - Your handy search suggestions tool
1.11
false
support@predictad.com
Forecastfox Weather
2.0.2
true
{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
ScrapBook
1.3.7
false
{53A03D43-5363-4669-8190-99061B2DEBA5}
ReloadEvery
4.0.0
false
{888d99e7-e8b5-46a3-851e-1ec45da1e644}
ReminderFox
1.9.8.4
true
{ada4b710-8346-4b82-8199-5de2b400a6ae}
DownloadHelper
4.8.1
false
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Adblock Plus
1.3.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Tab Mix Plus
0.3.8.4
false
{dc572301-7619-498c-a57d-39143191b318}
Greasemonkey
0.8.20100408.6
false
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Feedback
1.0.3
true
testpilot@labs.mozilla.com
Status-4-Evar
2010.11.20.19
true
status4evar@caligonstudios.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.casesensitive
1
accessibility.typeaheadfind.flashBar
0
browser.fixup.alternate.enabled
false
browser.history_expire_days.mirror
20
browser.history_expire_days_min
900
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.facebook.com/?ref=hp
browser.startup.homepage_override.buildID
20101104131838
browser.startup.homepage_override.mstone
rv:2.0b7
browser.tabs.warnOnClose
false
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
dom.max_script_run_time
1800
extensions.lastAppVersion
4.0b7
font.size.fixed.x-western
14
font.size.variable.x-western
17
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
network.security.ports.banned
8118,8123,9050,9051
places.history.expiration.transient_current_max_pages
128801
places.last_vacuum
1290435423
print.print_printer
Microsoft XPS Document Writer
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
true
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_pagedelay
500
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11,00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size
33685761
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8,50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1,00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.cpd.cookies
false
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.default_personal_cert
Select Automatically
security.warn_entering_weak
false
security.warn_entering_weak.show_once
false
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false
Graphics
Adapter Description
NVIDIA GeForce 8800 GT
Vendor ID
10de
Device ID
0611
Adapter RAM
512
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.17.12.6099
Driver Date
10-16-2010
Direct2D Enabled
true
DirectWrite Enabled
true
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

Chosen Solution

Try to set the pref gfx.font_rendering.directwrite.enabled to false on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
See http://kb.mozillazine.org/about%3Aconfig

You can also try to disable: Tools > Options > Advanced : General: Browsing: [ ] "Use hardware acceleration when available"

Question owner

yes, thank you! ;)

And that was really fast answer, wow :D

Actually, the gfx.font was set to false already...but the hardware acceleration was the problem. It crashed my ff when i tried to uncheck it! But the second time it was ok, after a little struggling with it...

I also tried how things look like with hardware acceleration turned on, and gfx.font rendering true, but it was similar. Only the font was then a little less bolded than before, although still fuzzy.

thanks again, best regards

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

You're welcome

You can try this test:

ElimGarak 0 solutions 2 answers

None of these options worked for me. The fonts still looked fuzzy. The only way I could get things to look normal was with the Anti-Aliasing Tuner add-on. That made the fonts look better than in 3.6. As good as Chrome, in fact.

https://addons.mozilla.org/en-US/firefox/addon/anti-aliasing-tuner/?src=api

I set everything to ClearType + GDI Classic. It was a huge improvement. Just make sure to turn hardware acceleration back on, because the add-on tweaks HW settings. If HW acceleration is off, the tuner can't do anything.

The only problem is that the spacing between letters for non-fixed width fonts is now off. The system is apparently trying to keep the exact same pixel width of a line of text while messing with the letters. Which results in variable spacing between individual letters.

Modified by ElimGarak

HanDuet 0 solutions 1 answers

Oh, great. So I can't have both hardware acceleration and readable text? Is this going to be a permanent problem of Firefox 4, or is this something that can be fixed?

ElimGarak 0 solutions 2 answers

Helpful Reply

OK, I give up on this. All of the solutions I've seen either lead to weird spacing between letters or fuzzy fonts. Until Firefox and IE fix this, I am going to stick with Chrome. I love FF, but they drove me away by breaking the most basic feature imaginable - font rendering. FF needs to either move away from DirectWrite or find a way to tune things so that fonts aren't fuzzy.

gwmbox 1 solutions 12 answers

Helpful Reply

Why is the 'so called' solution a need to turn off 'so called' features of Firefox 4? I mean were these features not meant to be a part of Firefox 4 to make it better or at least as good as Chrome?

It is a sad time for Firefox when people are saying that Firefox does not compare or is nearly comparable to Chrome. It should be as good or better, or has the bar for quality for Firefox as a browser been lowered?

Like many others I will have to revert back to FF3.6.16 and use Chrome now as my default browser... such a shame as Firefox 4 was meant to be so good.

GW

marien 0 solutions 5 answers

I solved this problem with Internet Explorer 9 by simply activating the compatibility mode. Is there a compatibility mode in Firefox too? I stick on the 3.6 version until I find a solution

Modified by marien