X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't update my Firefox. it is stuck at version 2.0

Posted

I can't seem to update my firefox as it is stuck on version 2.0. Went to the Firefox Addon page and the page detected my firefox as version 2.0.

I tried uninstalling my firefox and reinstall (with a newer version) it but it is still detected as Version 2.0

Chosen solution

You appear to have Firefox 3.6.12, you just need to reset your user agent string (identifies the version of Firefox). For details of how to do that see the Websites say that Firefox is outdated or incompatible even though it's the latest version article.

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

No idea.

Installed Plug-ins

  • npCsWebLauncher
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Nexon Game Controller
  • Pando Web Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/2.0 ( .NET CLR 3.5.30729; .NET4.0E)

More Information

No troubleshoot information

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

You appear to have Firefox 3.6.12, you just need to reset your user agent string (identifies the version of Firefox). For details of how to do that see the Websites say that Firefox is outdated or incompatible even though it's the latest version article.

Question owner

Thanks for the quick reply!