X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox can't see comments from sites using disqus sytem unless I start in safe mode.

Posted

TalkingPointsMemo and Anchorage Daily News changed to Disqus for their comments system. Suddenly I can't see the comments. I contacted TPM and enabled cookies and third party cookies, etc. per their tech person. Still doesn't work unless I start in safe mode. I was using Firefox 3.6 and tried uninstalling and going back to 3.5. Installed and uninstalled several programs, etc. Nothing works. It works in IE8 and Google Chrome so I cannot figure it out. Any clues?

Additional System Details

Sites Affected

http://talkingpointsmemo.com

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Adobe Acrobat Plug-In Version 5.00 for Netscape
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.15) Gecko/20101026 Firefox/3.5.15

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24397 answers

If it works when you are running in the Firefox SafeMode, one of your addons is probably causing that issue in the normal mode.

http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

mightymike 0 solutions 1 answers

Helpful Reply

I narrowed it down to the Ghostery extension. Go in its settings and remove Disqus from the "Bugs" list.

uniquolol 0 solutions 1 answers

Helpful Reply

@mightymike:

Thanks a lot!

Modified by uniquolol

theroux 0 solutions 1 answers

Solved this on my PC by changing back network.http.sendRefererHeader to its default value of 2. Accessable via about:config

http://kb.mozillazine.org/Network.http.sendRefererHeader

brucek2 0 solutions 1 answers

On my system the conflict turned out to be the "HTTPS Everywhere" extension.

Palomares 0 solutions 2 answers

I had this problem, so I came to this area and tried the suggestions. I disabled my add-ons, one by one. No dice. I unclicked Hardware Acceleration. No dice. I went to the default appearance theme. No dice. I went to Safe Mode, and it solved the problem. However, you don't want to stay in Safe Mode permanently, and when I went back to regular mode, the problem reappeared.

Finally, I lit a stick of dynamite, and reverted to the default Firefox, which zaps all the stuff you have added except for bookmarks and a very few other things. By the way, if you go that route, and it's not that hard to get back to normal afterwards, be sure and note which add-ons, themes, etc., you are now using if you want to reinstate them. Memory likely won't cut it.

Well, anyway, as I reinstated add-ons, I found the problem. It was the No-Script add-on. I had disabled it previously, but I had not deleted it. Apparently, deleting it did the trick. Disabling was not sufficient.

So, in my case at least, it was No-Script. Now I can see Disqus comments again.

Modified by Palomares