X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox opens a new tab every time I click a link. I just want the browser to go there, but can't find an option to fix that. Help.

Posted

Firefox opens a new tab every time I click a link. When I click a link, I just want to go there, not open a new tab. This slows my computer, but I can't find an option to fix it in the tools.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.1 r82
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50917.0
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

Windows 7, Firefox 3.6.12

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

Coding on webpages usually determines whether a hyperlink will open in the same window or a new window. There's a preference in Firefox that allows the user to have new windows diverted to a new tab instead. So if those pages are meant to open in a new window, your choices are the new window or a new tab. There is no preference to have all hyperlinks open in the same window /tab.

Just to make sure that something you added to Firefox hasn't changed the default actons for hyperlinks, why not try the Firefox SafeMode and see id that changes the action from those hyperlinks.
http://support.mozilla.com/en-US/kb/Safe+Mode

Question owner

This problem is in reference to links that should direct the browser. These same links functioned correctly in FireFox 3.6.8 and still work right in IE. I would much rather use FireFox, so if you could help solve this, I would appreciate it. Thank you.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

Did you have that problem when you had the Firefox SafeMode running?

Question owner

Yes, this problem is exactly the same when I use the safe mode.

Question owner

I guess this means I'll have to use a different browser or have a bunch of unwanted tabs. It's been a while since I heard anything about this. Does anyone have any ideas?

KC8384 0 solutions 1 answers

Helpful Reply

Had this same problem and found a solution way down on Google's responses to 'firefox opens a new window everytime'. The key was that it wasn't an issue of where NEW pages were opening, but that any link, even a redirection, was opening a new page. Don't know if Mozilla let's me link to another page in these responses, so I'll cut and paste part of the solution I found. Worked perfectly for me.

"Occasionally, Windows will miss a "change of state" on one of the "state shift" keys. The SHIFT, CTRL, and ALT keys are all "state shift" keys (and so, actually, is the CAPS LOCK).

In order for them to function as expected, Windows has to "see" them go down (key press) and "see" them go up (key release). This is the responsibility of the keyboard driver, a low-level chunk of code that sits and stares at switches and barks when stuff happens. Occasionally, in the course of its busy life, Windows won't hear the driver code "bark" and it will miss a change of state, and will continue to believe that one of the shifting keys is still down when it has actually been released.

So you will suddenly get mouse clicks that do weird things. Key presses will have unexpected effects. So, I have found a quick remedy for this, which pretty much works all the time. Mostly. I call it "the shift keys dance."

I will tap each of the shifted state keys and release it. Both ends of the keyboard. Can be done a couple of times for good measure. It's quick: tap, tap, tap, . . . tap, tap, tap, . . . tap, tap. Repeat as needed. "

So, not a Firefox issue but certainly shows up as one.

azzbar 0 solutions 1 answers

Helpful Reply

This problem sucks and I have no idea what causes it, BUT I do know the steps I took and one of them fixed it, pretty simple. I reinstalled Firefox but the problem continued, I then clicked the Firefox button(Firefox 4, though I'm sure this choice is somewhere) and clicked help, the option to restart Firefox with add-ons disabled (I thought it was ad-block, it wasn't) comes up. When you do this you will have the option of restoring Firefox to all the default settings, do that, once I did that the problem was resolved, there is probably an easier way of getting to the default settings option but that's how I got there. I don't know what setting was reset to fix this issue and most people seem to misunderstand the problem, but there you have it. Hope it works!

si37788 0 solutions 1 answers

Go to tools/options,/general, restore homepage to default, worked for me. :0)

Modified by si37788

nameless215 0 solutions 1 answers

Hey kc8384 thanks for the fix you were completely right i actually came to the same conclusion about 5 mins earlier guess i didn't have the "tap, tap, tap, . . . tap, tap, tap, . . . tap, tap." down yet hahaha. Anyways thanks again peace

ashleyh 0 solutions 1 answers

in the firefox options menu in the tabs location unclick "open new windows in a new tab instead" PROBLEM SOLVED!

wmatuszak 0 solutions 1 answers

Easiest way to fix the issue is to simply restart your computer. I did it and it worked perfectly

andys_dad 0 solutions 1 answers

thanks KC8384, it seems to be the control key which determines whether a new tab is opened. Clicked it twice and end of problem

St3hLy 0 solutions 2 answers

I had this same problem and it was really starting to piss me off. I reinstalled firefox, disabled add ons, tried the shift key thing and none of them worked. It actually has nothing to do with firefox. If you are using yahoo as your homepage/ search bar, search for something and on the right side of the search bar click options > preferences and at the bottom under Display & Layout it should say "Open results in a new tab or window". If there is a yes after it change it to no and it should fix the problem. Hope this helps some people out as I was really starting to get frustrated.

St3hLy 0 solutions 2 answers

All you're doing then is opening new windows instead of tabs.

barbarav 0 solutions 1 answers

The following just fixed it for me: Go to firefox Options and select "Tabs". At the bottom of the list, UNclick "Show tab previews in the windows taskbar".

The problem started for me today, and I realised that yesterday I had clicked that option to see what it does. Now I know ...!

I'm using firefox 13.0.1.