Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot get Flash to work with CentOS

more options

Hey guys,

I've tried copying the plugin (libflashplayer.so) almost everywhere it should be (read: places pointed by Mozilla's help, and also some other location pointed by user on the web) but still no Flash ... it there a specific location for Firefox 4? It does work for Firefox 3.

I've also the root permission so I can place libflashplayer.so anywhere.

Thanks

Chosen solution

Which location did you try?

A symlink to the file in /usr/lib/mozilla/plugins should work.
You can also create a directory plugins in the Firefox installation directory and place the symlink in that directory.
The plugins folder no longer exists by default in Firefox 4 because the only plugin in that folder (libnullplugin.so) is no longer used, so you need to create it.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Which location did you try?

A symlink to the file in /usr/lib/mozilla/plugins should work.
You can also create a directory plugins in the Firefox installation directory and place the symlink in that directory.
The plugins folder no longer exists by default in Firefox 4 because the only plugin in that folder (libnullplugin.so) is no longer used, so you need to create it.

more options

That worked (: Also I had a x86_64 libflashplayer.so. I think that was one of the problem since the firefox beta archive is probably a 32 bit version by default.

So I did a symlink from the 32 bit nswrapper: sudo ln -s /usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so ~/firefox/plugins/libflashplayer.so

Thanks a lot.