X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4b7 doesn't play flash videos anymore. 4b6 was fine.

Posted

Firefox 4b7 (on Mac) doesn't play YouTube videos anymore.

I checked on other video sites, same problem. Could be a flash thing?

It was doing fine as 4b6 until I upgraded.

Modified by monkster

Additional System Details

Sites Affected

http://www.youtube.com

Installed Plug-ins

  • doubleTwist Web Plugin
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.0 r45
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

More Information

linschn 0 solutions 1 answers

I reinstalled the flash plugin from http://get.adobe.com/flashplayer/ and now it works again.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

monkster:

Your Your More system details list shows an old Shockwave Flash 10.0 r45 plugin.

Update the Flash plugin to the latest version.

Question owner

Thanks for the tip!

I've installed the newest Flash and it's working now.

nlkflint 0 solutions 10 answers

Reinstalling does not work for me. Tried twice. Can view just fine on other browsers.

nlkflint 0 solutions 10 answers

Reinstalled firefox and flash, still no go.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

nlkflint,

Are you using Firefox 4.0b7 on MacOSX, like the user who started this thread?

If not, which version of Firefox are you using, and on which Operating System?

If you're using Windows, are you aware that there are two versions of Flash available? One for IE (ActiveX version) and one for other browsers such as Firefox, which use the Plugin version.

nlkflint 0 solutions 10 answers

Using Firefox 4.07b on Mac OSX 10.6.5.. I updated my Mac software. I uninstalled 4.07b and reinstalled. I did the same with Flash. No go. Lots of quirky Flash problems, I see my spinning ball ALOT and I never have before the last 2-3 days. I cannot load youtube videos at all. I have no trouble doing the same on Safari or IE, but I don't like using them. How can I go back to 4.06?

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Does the Flash plugin work correctly on the Adobe test page?

Does it work better if you disable OOPP for the Flash plugin?

nlkflint 0 solutions 10 answers

The test works on IE and Safari but not with Firefox.

nlkflint 0 solutions 10 answers

I don't know how to disable OOPP nor do I care to. How can I just go back to 4.06?

citizensweeps 0 solutions 1 answers

Helpful Reply

I had this same problem. I'm on OS X 10.6.5, now running Firefox 4 B7.

The problem was finally resolved for me by uninstalling Flash and reinstalling the latest build of the 64-bit version. You can find the downloads here.

schmichael 0 solutions 1 answers

Helpful Reply

citizensweep's solution worked for me on OS X 10.6.4 as well :)

Just to note that I quit uninstalled the 10.1 release version of Flash using the Uninstaller at the download link posted above, and installed the 10.2 prerelease.

Now youtube and other flash sites are working great!