X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why Firefox switched to bing instead of google without asking me ?

Posted

I've updgraded to Firefox 4.6 beta to 4.7 Yesterday everything was ok Today when I search something it goes to Bing ! I don't mind if you suggest to go to Bing instead of Google, but there you're FORCING me to this change and I HATE that ! More than this, nothing clear in the options show how to change of default search engine ! WTF ?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r85
  • DivX Web Player version 2.0.0.254
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • getplusplusadobe16290
  • Version 1.0.3, copyright 1996-2009 The VideoLAN Teamhttp://www.videolan.org/
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe Acrobat Plug-In Version 6.00 for Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Firefox includes a few default search engines. Bing was added as one of the defaults in 4.0b7 but still includes Google. You can easily switch back to Google, for details see the Search bar - Easily choose your favorite search engine article. It remembers the last search engine that was selected and when you next open Firefox will use that search engine.

Question owner

I wasn't speaking about the search engine bar but about the default search engine when we type something into the adress bar. I'm well aware about how to add search engine, but how can I change the default search engine in the adress bar ?

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

I just tried it on a fresh installation of 4.0b7 and it defaulted to Google. Check the following hidden preference:

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL, does it contain a link for Bing? If it does right-click on it and choose Reset, that should blank out the preference and it should default to Google.

An alternative is to double-click on the preference and set it to the following:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

That is the Google "Browse by name" search used in Firefox 3.6.*

Question owner

Ok, that was it. Weird it did changed by itself, or maybe it's a website which changed this without telling me ? (in that case that's a serious security issue)

Anyway, thanks a lot for your help :)

mjaggard 0 solutions 1 answers

When I loaded Firefox 4.0b7 on Windows 7, it's come up with Bing as the default search engine for the search box and Bing is the only option. :-(

about:config shows the following keys...

browser.search.defaultenginename;Google browser.search.order.1;Google browser.search.order.2;Yahoo browser.search.order.3;Bing

I'd really rather not use Bing, it is shockingly bad at finding what I'm looking for.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Try to restore the default search engines.

Left-click the search engines icon on the search bar, open "Manage Search Engines" and click "Restore Defaults"

You can also try to delete search.sqlite and search.json in the Firefox Profile Folder

  • Help > Troubleshooting Information > Profile Directory > Open Containing folder
Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

A number of extensions will do this when they install/update. Check in Tools > Add-ons

bchiud 0 solutions 2 answers

Helpful Reply

1) type "about:config" into the address bar 2) search "keyword.URL" 3) modify value to "http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q="

bchiud 0 solutions 2 answers

1) type "about:config" into the address bar 2) search "keyword.URL" 3) modify value to "http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q="

Sevian 0 solutions 1 answers

In Firefox 4.0 (or higher) you can change default search engine in a way described above (about:config and so on...) , but after minute or two Bing can be back. It's because add-on called Personas Interactive. Choose manage add-ons and unmark Use Bing in Personas settings. Hope it helps. (Only Bing allowed in my PC is Chandler!)

lindsaygii 6 solutions 14 answers

Opening Firefox in Safe Mode and changing the defaults back to all Firefox worked for me. And this has been driving me nuts for weeks, so I'm very glad to find the fix"

Someone earlier in the thread posted a screenshot of the dialogue box.

The 'about.config' fix is no good, because when you type about.config in the address bar it can't find it, because Bing has taken over!  :)