X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4 won't let me organize my bookmarks.

Posted

When I try to organize my bookmarks. Nothing happens.

Additional System Details

This happened

Every time Firefox opened

This started when...

Just now

Installed Plug-ins

  • Unity Web Player lets you experience dazzling interactive 3D right in your browser. For more information, visit Unity .
  • npmnqmp 071701000001
  • http://www.facebook.com/fbplugin/
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • iPhoto6
  • Juniper Networks Safari Extensions
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r85

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

More Information

dubkatz 0 solutions 1 answers

Helpful Reply

try ctrl+shift+b

tested in firefox 4 beta 7

-dubby

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

This can also be a problem with the file places.sqlite that stores the bookmarks and the history.

CMonster 0 solutions 1 answers

Many thanks. I couldn't find the menu anywhere in FF4. Didn't feel that I should need to load a 3rd party sync app to get the job done.

dgbrowsing 0 solutions 1 answers

Does anyone know if there is a similar trick to organize bookmarks on a Mac?

uncertain7255 0 solutions 2 answers

Try Command-shift-b on OS X

I don't know why the "Organize Bookmarks" doesn't show up under Bookmarks when you click on it, but it doesn't. Even when you try "Help" it tells you to click on "Organize Bookmarks" under "Bookmarks." It looks like an oversight to me. But such an obvious one.

Modified by uncertain7255

eyeoman 0 solutions 1 answers

I've just tried Command-shift-b on OS X with FF 4 and it does give me the window for organising bookmarks but when I click on the little sun icon (or whatever it is) to bring up the new folder, new bookmark, etc. menu, it is all greyed out. I also found that the help feature just tells me to click on "Organise bookmarks" under "Bookmarks". Any other suggestions?

kittyleen 0 solutions 1 answers

Thanks -- ctrl+shift+b works. But I am incredibly irritated that I now must press 3 keys AND remember which keys to press, instead of simply clicking the mouse on an easy-to-find tab. Is the old "Organize Bookmarks" menu item really gone for good? Can the FF4 designers be that stupid??

Modified by kittyleen

abramsob 0 solutions 1 answers

Helpful Reply

It has just been renamed Show All Bookmarks

uncertain7255 0 solutions 2 answers

I don't know about the "little sun" you mention, but when I want a new folder, I "right-click" to the left of the existing folder icons on the left side of the "Organize Bookmarks" window that opens with "command-shift-b." That left-click (control-click if you don't have right-click enabled) opens a small window that offers several choices, including "New Bookmark" and "New Folder." Left-click on that selection to get a New Bookmark or New Folder.

As for the complaint that it takes multiple actions to get to the "Organize Bookmarks," I assume as soon as Mozilla understands this oversight, they'll correct it by putting "Organize Bookmarks" back in the Bookmarks dropdown menu.

Note: Thanks to abramsob, I see that "Show All Bookmarks" does perform the same function as the old "Organize Bookmarks." Looks like they are trying to confuse us. I don't know if that selection has always been there, but I didn't notice it until abramsob mentioned it above. Thanks.

Hope this helps.

Modified by uncertain7255

butlerg 0 solutions 1 answers

These guys are starting to remind me of M$, If I wanted the ignition key moved some where different every time I started the key I'd buy Microsoft. Beginning to wish I'd never changed...

RRGELMAN 0 solutions 1 answers

Thank you, so simple if you know about it. Read 8 relies with all kinds of control shifts before yours came up, which made sense and worked. Thanks again, Ron

ThomasJThomas 0 solutions 3 answers

Today's Date 16th April 2011

Thanks abramsob you saved me a lot of time, I clicked Show All Bookmarks and I found myself in familiar circumstances.

Thanks Again 10/10

Modified by ThomasJThomas

HenryA 0 solutions 7 answers

What is wrong with the Mozilla people? "Organize Bookmarks" worked fine. Why did these assholes change it? And when are they going to get rid of the "Remove Bookmarks" crap. If I want to record 2 copies of a bookmark who are they to stop me? Firefox 4 was so frustrating that I removed it and went back to 3.6.16 If they keep "improving" it, it will not work any more. henryA

machswa 0 solutions 1 answers

That works fine, but I want the "Organize Bookmarks" link on the Bookmarks menu like before. I can't see any reason why it would be taken off.

Guzziman 0 solutions 1 answers

This works for MAC, should work for PC . On the far right side of the Firefox 4 bookmarks toolbar, open bookmarks which is below the homepage icon. Highlight the bookmark to change. Click on the drop down with the wheel icon, just right of the advance symbol. Highlight the bookmark to move or delete and press on. Just like the 3.00.00.00 system.

tatyrb 0 solutions 1 answers

I dont like that i cant organize my bookmarks anymore.I wanted to sort out my bookmarks tab and no option!!Whats going on??Help please!

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers
  • "Bookmarks > Organize Bookmarks" has been renamed to "Show All Bookmarks" in Firefox 4.
  • Click the orange Firefox button to open the Firefox menu and click the Bookmarks entry or click "Show All Bookmarks" to open the Library.

Some menu entries are hidden by default and only appear if you use the keyboard to open the menu.

You can see the difference if you use Alt+F or Alt+B to open the "File" and "Bookmarks" menu and compare that to what you see if you use the mouse to open the menu after you have made the menu bar visible by tapping Alt or by pressing F10.

  • "Bookmark All Tabs" (Shift+Ctrl+D) no longer shows in the Bookmarks menu unless you open the Bookmarks menu via the keyboard (Alt + B).
  • "Bookmark This Page" can be accessed via the right-click context menu of that browser page.
  • "Bookmark All Tabs" can be accessed via the right-click context menu of a tab on the tab bar.
Robeespenc 0 solutions 4 answers

This update is really dreadful.

NOTHING has improved they have just made it less user friendly. We cannot organise bookmarks. We get tabs when we dont want them. Opening new pages is much slower. What a total waste of time.

Robeespenc 0 solutions 4 answers

This update is really dreadful.

NOTHING has improved they have just made it less user friendly. We cannot organise bookmarks. We get tabs when we dont want them. Opening new pages is much slower. What a total waste of time.