X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 3.6.12 is not working with Youtube

Posted

Re. Firefox 3.6.12 and Youtube.com:

Searches of Youtube.com using the Web site's search feature are not working, and texts provided with video clips are not expanding. When I click on Search and click on the little icon or button (whatever it's called, downward arrows anyway) to expand the text posted with video clips, nothing happens. This never happened, before, with earlier versions of Firefox; not for me, anyway.

I think this started happening only today, or this week anyway, and also think to have used Youtube since upgrading to Ffx 3.6.12 while being able to expand text with video clips and possibly Youtube searches, but don't precisely recall when Ffx was upgraded to 3.6.12.

However, neither is presently working. There's a problem at one end or the other, now.

Actually, and this is an update to the original post on this problem, I just clicked on the "Like" button at Youtube for a video clip and this also doesn't work.

Re. Firefox 3.6.12 and Youtube.com: Searches of Youtube.com using the Web site's search feature are not working, and texts provided with video clips are not expanding. When I click on Search and click on the little icon or button (whatever it's called, downward arrows anyway) to expand the text posted with video clips, nothing happens. This never happened, before, with earlier versions of Firefox; not for me, anyway. I think this started happening only today, or this week anyway, and also think to have used Youtube since upgrading to Ffx 3.6.12 while being able to expand text with video clips and possibly Youtube searches, but don't precisely recall when Ffx was upgraded to 3.6.12. However, neither is presently working. There's a problem at one end or the other, now. Actually, and this is an update to the original post on this problem, I just clicked on the "Like" button at Youtube for a video clip and this also doesn't work.

Modified by mikecorbeil

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Shockwave Flash 10.1 r85
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • DivX Web Player version 2.0.0.254
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

JDR23 0 solutions 1 answers

I'm having the same problem with YouTube, and it's also showing up in Gmail. Though I can access my Inbox fine, I cannot use many of the other buttons including "Reply" and access to Buzz. The buttons seem to register that my cursor is over them, and that I am clicking them, but I receive no response after the click. However, Gmail functions correctly in basic HTML mode.

Edit: I am running Firefox 3.6.12 in Mac OS X 10.4.11.

I'm having the same problem with YouTube, and it's also showing up in Gmail. Though I can access my Inbox fine, I cannot use many of the other buttons including "Reply" and access to Buzz. The buttons seem to register that my cursor is over them, and that I am clicking them, but I receive no response after the click. However, Gmail functions correctly in basic HTML mode. Edit: I am running Firefox 3.6.12 in Mac OS X 10.4.11.

Modified by JDR23

t002 0 solutions 3 answers

Helpful Reply

To solve the problem:

1) Access your about:config page in your Firefox by typing about:config in the address bar.

2) Double click on the dom.storage.enabled entry to change the value from false to true.

It seems not to be a Firefox problem, but that from now youtube + gmail won`t work without flash cookies.

http://en.wikipedia.org/wiki/Local_Shared_Object

Maybe "the next front in the cookie wars?" http://blogs.techrepublic.com.com/security/?p=4672&tag=nl.e550

EDIT: wired article about Flash cookies http://www.wired.com/epicenter/2009/08/you-deleted-your-cookies-think-again

The Better Privacy extension for Firefox allows to delete Flash cookies https://addons.mozilla.org/en-US/firefox/addon/6623/

To solve the problem: 1) Access your ''about:config page'' in your Firefox by typing ''about:config'' in the address bar. 2) Double click on the ''dom.storage.enabled'' entry to change the value from false to true. It seems not to be a Firefox problem, but that from now youtube + gmail won`t work without flash cookies. http://en.wikipedia.org/wiki/Local_Shared_Object Maybe "the next front in the cookie wars?" http://blogs.techrepublic.com.com/security/?p=4672&tag=nl.e550 EDIT: wired article about Flash cookies http://www.wired.com/epicenter/2009/08/you-deleted-your-cookies-think-again The Better Privacy extension for Firefox allows to delete Flash cookies https://addons.mozilla.org/en-US/firefox/addon/6623/

Modified by t002

Question owner

Thanks t002.

The about:config change worked. And I just read the description of Better Privacy, which convinced me to install it. It was installed in the past, but I hadn't reinstalled the extension after reinstalling Windows and Ffx; installed plenty of other extensions, but not this one. And I probably thought NoScript would be enough, but now guess that it isn't.

The Wired and TechRepublic articles are interesting and I'll need to read these in full.

Thanks t002. The about:config change worked. And I just read the description of Better Privacy, which convinced me to install it. It was installed in the past, but I hadn't reinstalled the extension after reinstalling Windows and Ffx; installed plenty of other extensions, but not this one. And I probably thought NoScript would be enough, but now guess that it isn't. The Wired and TechRepublic articles are interesting and I'll need to read these in full.

Modified by mikecorbeil

Question owner

Try t002's solution in about:config. I'm using Win XP, but maybe the same change will work on the Mac. That one change corrected the multiple problems I was having at Youtube and maybe it'll work for all of your problems with the GMail Web site.

Try t002's solution in about:config. I'm using Win XP, but maybe the same change will work on the Mac. That one change corrected the multiple problems I was having at Youtube and maybe it'll work for all of your problems with the GMail Web site.
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158913 answers

Flash cookies (LSO) have nothing to do with DOM storage that is controlled by the pref dom.storage.enabled

See:

Flash cookies (LSO) have nothing to do with DOM storage that is controlled by the pref dom.storage.enabled See: * https://developer.mozilla.org/en/dom/storage (Storage location and clearing the data) * http://kb.mozillazine.org/Dom.storage.enabled
t002 0 solutions 3 answers

Helpful Reply

@cor-el

Thanks for clearing up my misunderstanding. As i understood now it is in fact only a "DOM storage data" topic.

Quote from betterprivacy:

"Disabling DOM storage (instead of deleting the file on shutdown) causes a website script to throw an exception. This means that the execution of the script is aborted immediately, not just the DOM storage instruction is ignored. None of the following script instructions would be executed, even if those instructions have nothing to do with DOM storage. That is the reason why -with DOM storage disabled- sites like CNN.com will cease to play videos."

@cor-el Thanks for clearing up my misunderstanding. As i understood now it is in fact only a "DOM storage data" topic. Quote from betterprivacy: ''"Disabling DOM storage (instead of deleting the file on shutdown) causes a website script to throw an exception. This means that the execution of the script is aborted immediately, not just the DOM storage instruction is ignored. None of the following script instructions would be executed, even if those instructions have nothing to do with DOM storage. That is the reason why -with DOM storage disabled- sites like CNN.com will cease to play videos."''

Modified by t002

Question owner

cor-el and t002,

If DOM storage should not be disabled, so that videos at CNN, f.e., will continue to play, then what is the solution for the problem(s) described in my initial post of this page or thread? It seems that I need to re-enable DOM storage, so since disabling it corrected the problems I was having at Youtube, do either of you know what the solution is or might be?

I think to understand that your discussion means to leave DOM storage enabled, anyway. But I'll keep it disabled for now, until getting a reply to this post, anyway. It's the only what that I presently know of being able to use the features at Youtube mentioned in my first post.

cor-el and t002, If DOM storage should not be disabled, so that videos at CNN, f.e., will continue to play, then what is the solution for the problem(s) described in my initial post of this page or thread? It seems that I need to re-enable DOM storage, so since disabling it corrected the problems I was having at Youtube, do either of you know what the solution is or might be? I think to understand that your discussion means to leave DOM storage enabled, anyway. But I'll keep it disabled for now, until getting a reply to this post, anyway. It's the only what that I presently know of being able to use the features at Youtube mentioned in my first post.

Modified by mikecorbeil

t002 0 solutions 3 answers

Hi, another solution in case you use NoScript. Then you don`t have to enable Dom storage.

Attach the following two lines of code to your user.js:

user_pref("noscript.surrogate.localStorage.sources", "@^https?:"); user_pref("noscript.surrogate.localStorage.replacement", "try { window.localStorage; } catch(e) { __defineGetter__('localStorage', function() {return null;}); __defineGetter__('sessionStorage', function() {return null;});}");

This solution was found by al_9x

http://forums.informaction.com/viewtopic.php?f=23&t=5208&sid=60cac51811d0a4ff91b8dc1e98a49a22&start=15

https://bugzilla.mozilla.org/show_bug.cgi?id=527970

Hi, another solution in case you use [http://noscript.net NoScript]. Then you don`t have to enable Dom storage. Attach the following two lines of code to your [http://kb.mozillazine.org/User.js_file user.js]: user_pref("noscript.surrogate.localStorage.sources", "@^https?:"); user_pref("noscript.surrogate.localStorage.replacement", "try { window.localStorage; } catch(e) { __defineGetter__('localStorage', function() {return null;}); __defineGetter__('sessionStorage', function() {return null;});}"); This solution was found by al_9x http://forums.informaction.com/viewtopic.php?f=23&t=5208&sid=60cac51811d0a4ff91b8dc1e98a49a22&start=15 https://bugzilla.mozilla.org/show_bug.cgi?id=527970

Modified by t002

Robespierre 0 solutions 1 answers

Thanks too2.

Your about:config solution works perfectly.

Thanks for saving me from having to use IE.

Thanks too2. Your about:config solution works perfectly. Thanks for saving me from having to use IE.
sedim1 0 solutions 1 answers

Thank you. It worked, at least on my laptop running Windows XP. I will try it on my Mac when I get home.

How do you guys know this stuff? Glad you do though.

Thank you. It worked, at least on my laptop running Windows XP. I will try it on my Mac when I get home. How do you guys know this stuff? Glad you do though.

Question owner

t002,

Thanks for the user.js information. I just checked for the file in my Ffx profiles and there isn't a file with this name there. So I'll create it with only the two NoScript settings that you say can be used instead of disabling DOM storage.

And since DOM storage then doesn't need to be disabled, I'll set its value back to enabled in order to leave it at its default value and then have one less change to remember.

t002, Thanks for the user.js information. I just checked for the file in my Ffx profiles and there isn't a file with this name there. So I'll create it with only the two NoScript settings that you say can be used instead of disabling DOM storage. And since DOM storage then doesn't need to be disabled, I'll set its value back to enabled in order to leave it at its default value and then have one less change to remember.
cinco312 0 solutions 1 answers

I can't play no Youtube videos at all. I tried doing the "dom.storage.enabled" but it was already set to true. I set it false, reboot, nothing, then back to true and it still don't play anything from Youtube.

I can't play no Youtube videos at all. I tried doing the "dom.storage.enabled" but it was already set to true. I set it false, reboot, nothing, then back to true and it still don't play anything from Youtube.
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158913 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See

Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). * Don't make any changes on the Safe mode start window. See * [[Troubleshooting extensions and themes]]
gbolcer 0 solutions 9 answers

AdBlock 1.3.1 plus was the culprit. Youtube vids working fine now. I had NoScript, Adblock, Ghostery (turned off), 1Click Youtube download, so it was a pretty complicated environment.

AdBlock 1.3.1 plus was the culprit. Youtube vids working fine now. I had NoScript, Adblock, Ghostery (turned off), 1Click Youtube download, so it was a pretty complicated environment.
honestbroker2 0 solutions 2 answers

I disabled AdBlock and I got my YouTube function back. So apparently this version of AdBlock has some issues and needs work.

I disabled AdBlock and I got my YouTube function back. So apparently this version of AdBlock has some issues and needs work.
c_laverne 0 solutions 7 answers

I FINALLY SOLVED MY HANGING, "STOPPED" LOADING AND FORCE QUIT PROBLEMS AFTER TRYING EVERYTHING SHORT OF ARCHIVE AND INSTALL.

I FINALLY SOLVED MY HANGING, "STOPPED" LOADING AND FORCE QUIT PROBLEMS AFTER TRYING EVERYTHING SHORT OF ARCHIVE AND INSTALL: I HAD TO RESTART "FORCED" TEN TIMES A DAY:

I UPDATED JAVA:

Java for Mac OS X 10.5 Update 9 http://support.apple.com/kb/HT4438

also

JavaEmbeddingPlugin 0.9.7.5

I have a PPC G5 dual 2.0 OSX 10.5.8

Firefox 3.6.16

I FINALLY SOLVED MY HANGING, "STOPPED" LOADING AND FORCE QUIT PROBLEMS AFTER TRYING EVERYTHING SHORT OF ARCHIVE AND INSTALL. I FINALLY SOLVED MY HANGING, "STOPPED" LOADING AND FORCE QUIT PROBLEMS AFTER TRYING EVERYTHING SHORT OF ARCHIVE AND INSTALL: I HAD TO RESTART "FORCED" TEN TIMES A DAY: I UPDATED JAVA: Java for Mac OS X 10.5 Update 9 http://support.apple.com/kb/HT4438 also JavaEmbeddingPlugin 0.9.7.5 I have a PPC G5 dual 2.0 OSX 10.5.8 Firefox 3.6.16
steve.gothica 0 solutions 1 answers

disable adblock - youtube upgraded it now insists on adds

disable adblock - youtube upgraded it now insists on adds