Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

gmail slow and hangs on 'compose', 'forward', 'sent', etc. since most recent upgrade

  • 5 replies
  • 48 have this problem
  • 173 views
  • Last reply by hmscott

more options

cleared all history, etc. no issues using safari; no firefox problems on other websites or google calendar... just gmail functionality like hitting 'compose', 'forward', 'sent', etc.

All Replies (8)

more options

Make sure that the pref dom.storage.enabled is set to true on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

See also http://kb.mozillazine.org/about%3Aconfig

Modified by cor-el

more options

Thank You! Thank You! Thank You! Perfect fix — succinct and spot on...

All is well, where do I send the brownies?

more options

For some reason it's got fixed automatically, may be a reboot effect.

About the Config, I have my about.config set as follow dom.storage.enabled;true dom.storage.default_quota;5120

But the followings are of false value. Not sure if these contributed to the initial cause of Gmail and Youtube malfunction or not.

extensions.firebug.showDOMConstants;false extensions.firebug.DBG_DOMPLATE;false extensions.firebug.clearDomplate;false extensions.firebug.showDOMFuncs;false

more options

That are settings (extensions.firebug.*) that apply to the Firebug extension (Tools > Add-ons > Extensions).

Be aware that Firebug is listed as a problematic extension and cause problems on web pages.

more options

I already had dom.storage.enabled set to true - but still had hang / hour-glass when opening a gmail tab to my account and then clicking on a message to open.

Found a fix in about:config - I haven't tuned the final value, but adding a zero to dom.storage.default_quota default value:

From:

dom.storage.default_quota;5120

to:

dom.storage.default_quota;51200

stopped the hang / hour-glass; pretty snappy performance now :-)

Scott

more options

Under Windows 7:

Actually it looks like the dom.storage.default_quota wasn't the fix, it was how I started the browser.

If I start Firefox from the program icon / shortcut / taskbar icon, I get the hangs even with dom.storage.default_quota value increased.

Starting firefox via a .bat file I use to run more than one Firefox instance stops the hang / hour-glass:

@echo off set MOZ_NO_REMOTE=1 start "" "C:\Program Files (x86)\Firefox\firefox.exe" -ProfileManager set MOZ_NO_REMOTE=0

This works with dom.storage.default_quota at default 5120

To run more than one instance of Firefox you need multiple copies/installs of Firefox - you can't run multiple instances of the same .exe/install at the same time.

For this problem, just run the .bat on your single install of Firefox.

It looks like there is a command-line switch for this now, like -ProfileManager

-no-remote

That can simply be set in your shortcut:

Target: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -ProfileManager

-no-remote

I haven't checked to see if this problem /fix is needed under Linux / Mac OSX

Scott

more options

Odd, the .bat using MOZ_NO_REMOTE causes the problem to go away, but adding the -no-remote on the shortcut doesn't help - still get the hangs.

For now using the .bat is a usable work around, but a better solution is needed.

Scott

more options

Yup, creating a .bat file without the MOZ_NO_REMOTE also works to start a single instance of Firefox that doesn't hang in gmail:

@echo off start "" "C:\Program Files (x86)\Firefox\firefox.exe" -ProfileManager

Must be some initialization difference starting from .bat that fixes the problem.

Scott