Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't open emails from my hotmail inbox


I have read similar posts about problems with hotmail etc, but none specific. I can get in, open my inbox etc, but I cannot open an email, they are there, I can hover over the message but when I click nothing.... Actually on further probing I can't do anything. I can't see recent posts on this has they been a fix yet??

Additional System Details

Sites Affected


Installed Plug-ins

  • 2.0.0048.0
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.5
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50917.0
  • Office Live Update v1.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers


  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv: Gecko/20101012 Firefox/3.6.11 (.NET CLR 3.5.30729)

More Information

dnhou 0 solutions 1 answers

Is a team at Firefox working on this hotmail issue? It just started happening to me last week. Very annoying because I hate internet explorer. But that is the only way I can read my emails. Please let me know when you can fix this problem.

xianguang 0 solutions 1 answers

I got the simplest solution occasionally:

the same problem happened after I clear all recently history.

After I try to "Start Private Browsing" from "Tools" menu, go into hotmail, everything comes back to work. but I don't know the reason.

Hope this can help you guys too.

Sheumais 0 solutions 1 answers

Helpful Reply

I had this problem and have discovered it was due to an update of my PDF reader. I have now removed the Foxit PDF Reader and can access Hotmail messages without any problem. Hope this helps.

You can disable the plugin to try for yourself by going to Tools, Add-ons, Plugins and disabling them using the button on the Manager screen.