X
Tap here to go to the mobile version of the site.

Support Forum

I just upgraded Firefox, and now it's opening new windows instead of news tabs when I click on links. It's driving me nuts. How do I get pages I click on to open in new tabs instead?

Posted

I'm using Firefox 3.5.14, and had no similar problems with an earlier edition.

I believe I've already selected the "open in new tab" option. Am I missing something?

I'm using Firefox 3.5.14, and had no similar problems with an earlier edition. I believe I've already selected the "open in new tab" option. Am I missing something?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r53
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • DivX Web Player version 1.4.2.7
  • Adobe PDF Plug-In For Firefox and Netscape
  • NPCIG 1.0.0.3
  • BitTorrent Plugin 1
  • np-mswmp
  • Provides additional functionality on Facebook. See our web site for details.
  • iTunes Detector Plug-in
  • Picasa plugin
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Java(TM) Platform SE binary

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.14) Gecko/20101001 Firefox/3.5.14 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160812 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).
See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).<br /> See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]] If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. * Use "Disable all add-ons" on the [[Safe mode]] start window to disable all extensions. * Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")