X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why is firefox asking for administrator password or it wont open

Posted

I installed firefox 3.6.11 today on a Windows 7 Laptop and everytime I attempt to open it it keeps asking to log on as administrator and wanting my admin password

Additional System Details

This happened

Every time Firefox opened

This started when...

when I downloaded it today

Installed Plug-ins

  • getplusplusadobe16291
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50917.0
  • NPWLPG
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

More Information

blackdog69 0 solutions 1 answers

me to?

LindsayDianne 0 solutions 1 answers

I keep searching for this issue, and I'm finding tonnes of people having it and not a single person who has figured out what is wrong. One person said maybe it was the antivirus? Not as far as I can tell. This is a super annoying issue and I wouldn't even bother trying to install it if I didn't need it for an assignment.

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96844 answers

Check that you do not run Firefox as Administrator.

Right-click the Firefox desktop shortcut and choose "Properties".
Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program directory.

tomcatxyz 0 solutions 1 answers

Helpful Reply

Me too. This issue did drive me crazy, but I got a solution. 1. Save installation file on your harddisk 2. Right click on mouse 3. Execute (file) as administrator

This worked for me. The whole issue started, when I accepted an AUTOMATIC update of Firefox. After that update, Firefox redirected me always to browsersafesearch. Even about:config and changing the keyword.url to Google as the default search tool did not work. Everytime I started firefox newly the setting was on browsafesearch. Crazy... I did run AVIRA Virussoftware, and it indentified files with malware/viruses which were created exactly the date when Firefox updated. I remove Firefox and the infected files, re-install Firefox 8.0, which created (the first time ever) the Adminstrator issue.... Now I hope everything works fine, also for you

tennisdoc1 0 solutions 2 answers

this was a 24 hour nightmare--I deleted version 8 because my roboform was not syncing correcting with my Vista. Kept getting the run as error message and no password change up worked. Tried again today and the last tips seemed to help--icon was never on desktop tho--still in downloads---went from there as suggested and VOILA! my version 8 is back and my roboform with it too tennisdoc1/teresa

tennisdoc1 0 solutions 2 answers

this worked for me as less than a novice with computers but when laid out easily i can comprehend and do it--- thank you teresa

Digital Shankar 0 solutions 1 answers

Helpful Reply

I found a solution for this problem. Right click on the Firefox Setup file and select Properties > Compatibility tab > Select Run as Administrator or simply right click firefox setup file then select Run as administrator.

tanhailover 0 solutions 1 answers

It is so simple ... just click on the Firefox setup icon and then go to the "Compatibility tab" and then see the image attach with it... Problem solved

unhappyinin 0 solutions 1 answers

Mine also did this with windows 7, all I had to do was change my User Account Control to the lowest setting, restart the computer and then redownload. The User Account Control is in the Security settings, that is located in the control panel.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8035 answers

Locking due to age of original question.