X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox google search in address bar

Posted

Hey. Before I had this problem I would just put a word in the firefox address bar for popular pages such as facebook and it will go directly to facebook or I search there and it goes to google search results. Lately, when I put in the address bar such as 'google', it doesn't go to google or the search page. Instead it just goes to a blank page with http://google/ in the bar.

Yes, I have looked into the about:config and made sure everything is resetted the way it was. I have this:http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

yet, it's still not redirecting my searches in the firefox bar. I'm using 3.6.10 btw..

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • npdnu
  • npdnupdater2
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • 3.0.40624.0
  • NPWLPG
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Is the pref keyword.enabled also set to true?

keyword.enabled - see http://kb.mozillazine.org/keyword.enabled
browser.fixup.alternate.enabled - see http://kb.mozillazine.org/About%3Aconfig_entries#Browser.

Helpful Reply

Yes. But that wasn't the problem.

For some reason firefox was using a proxy, so I just setted to no proxy and everything was back to normal.

I believe i had a virus or something.

ericco 0 solutions 1 answers

Helpful Reply

I had the same problem. Here's the solution:

  1. Type about:config into your address bar.
  1. In the small filter box, type keyword.URL.
  1. Right click "keyword.URL" and click “Modify”. Copy and paste this into the popup box: http://www.google.com/search?btnG=Google+Search&q=
  1. Restart Firefox. This will cause the address bar to do a Google search again.