X
Tap here to go to the mobile version of the site.

Support Forum

Is it possible to upgrade FF 1.5.0.5 to anything better?

Posted

I've been using Xandros Deluxe Open Source 3.0 (a Linux-based operating system) since 2003. I've found it to be an extremely stable and reliable operating system that, after it's been updated to its maximum potential, can only run Firefox 1.5.0.5.

Is it possible to upgrade Xanros to something a bit more contemporary?

I've been using Xandros Deluxe Open Source 3.0 (a Linux-based operating system) since 2003. I've found it to be an extremely stable and reliable operating system that, after it's been updated to its maximum potential, can only run Firefox 1.5.0.5. Is it possible to upgrade Xanros to something a bit more contemporary?

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Ebrary Reader 3.2.2 - 051129
  • Mozilla ActiveX control and plugin module
  • Shockwave Flash 7.0 r19
  • Helix DNA Plugin: RealPlayer G2 Plug-In Compatible version 0.4.0.622 built with gcc 3.3.4 on Jul 19 2006
  • Shockwave Flash 7.0 r25
  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • Java(TM) Plug-in 1.4.2_06
  • The default plugin handles plugin data for mimetypes and extensions that are not specified and facilitates downloading of new plugins.

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.5) Gecko/20060626 Firefox/1.5.0.5 (Debian-1.5.dfsg+1.5.0.5.x.1-2)

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40083 answers
See if your operating system meets the system requirements for a later version of Firefox . http://www.mozilla.com/en-US/firefox/system-requirements-v2.html http://www.mozilla.com/en-US/firefox/system-requirements-v3.html http://www.mozilla.com/en-US/firefox/system-requirements.html

Question owner

I think my system more than meets the minimum hardware requirements.

CPU: AMD Duron™ 1800MHz

RAM: 2048MB

IDE HDD Free Space: ~20GB

But I don't have a clue how to confirm any of the software requirements largely because I don't know how to find the answers within my system.

However, simply because I don't know, doesn't mean the system doesn't know. I shall return later with (I hope) better data.

I think my system more than meets the minimum hardware requirements. CPU: AMD Duron™ 1800MHz RAM: 2048MB IDE HDD Free Space: ~20GB But I don't have a clue how to confirm any of the software requirements largely because I don't know how to find the answers within my system. However, simply because I don't know, doesn't mean the system doesn't know. I shall return later with (I hope) better data.

Modified by CdnGhost

cor-el
  • Top 10 Contributor
  • Moderator
17408 solutions 157260 answers

What you should check is whether your Linux distribution has the required libraries for the current Firefox version.

  • GTK+ 2.10 or higher
  • GLib 2.12 or higher
  • Pango 1.14 or higher
  • X.Org 1.0 or higher
What you should check is whether your Linux distribution has the required libraries for the current Firefox version. * GTK+ 2.10 or higher * GLib 2.12 or higher * Pango 1.14 or higher * X.Org 1.0 or higher

Question owner

My thanks to you, cor-el, but it would appear that my operating system is not sufficiently advanced. If I had Xandros 4.0, instead of Xandros 3.0, though the process would not be easy, but it would be possible.

I am, therefore, stuck with my Gmail in basic HTML until such time as I can afford the $99.99 required in payment for downloading an OEM Xandros Desktop Professional CD.

However, I thank you all for trying to assist me in this matter.

My thanks to you, cor-el, but it would appear that my operating system is not sufficiently advanced. If I had Xandros 4.0, instead of Xandros 3.0, though the process would not be easy, but it would be possible. I am, therefore, stuck with my Gmail in basic HTML until such time as I can afford the $99.99 required in payment for downloading an OEM Xandros Desktop Professional CD. However, I thank you all for trying to assist me in this matter.
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40083 answers

Why don't you look into a different Linux distro?
http://distrowatch.com/

Most are free, and have a LiveCD version that you can test before you commit to installing it.

Why don't you look into a different Linux distro? <br /> http://distrowatch.com/ Most are free, and have a LiveCD version that you can test before you commit to installing it.

Question owner

It's a good idea but about six months ago I paid $10 to http://www.ubuntu.com/%0A for one Ubuntu CD and have yet to receive it. And I can't go through my usual distributor as he's recently passed away.

Oh well, eventually I'll be able to afford the $100 version of Xandros and I can stand my mail the way it is until then.

My thanks to you, sir, for trying. I've bookmarked the website you've given me and later, when things aren't quite as hairy as they are now, I'll have a look through what they've got.

It's a good idea but about six months ago I paid $10 to http://www.ubuntu.com/%0A for one Ubuntu CD and have yet to receive it. And I can't go through my usual distributor as he's recently passed away. Oh well, eventually I'll be able to afford the $100 version of Xandros and I can stand my mail the way it is until then. My thanks to you, sir, for trying. I've bookmarked the website you've given me and later, when things aren't quite as hairy as they are now, I'll have a look through what they've got.