X
Tap here to go to the mobile version of the site.

Support Forum

My facebook page has lost all it's photos and yet if I log on with explorer they are all still there? Any ideas?

Posted

Whilst on FB a few days ago the page suddenly reloaded without any pictures although I am unaware of pressing anything in particular. Despite closing down and reopening they have not reappeared. However, when I log in via Explorer on the same computer the normal FB page with photos comes up.

Whilst on FB a few days ago the page suddenly reloaded without any pictures although I am unaware of pressing anything in particular. Despite closing down and reopening they have not reappeared. However, when I log in via Explorer on the same computer the normal FB page with photos comes up.

Chosen solution

With Facebook on display, click on the site identity button (for details on that button see the How do I tell if my connection to a website is secure? article) and then on More Information. This will open up the page info dialog.

First select the Permissions panel, make sure that "Load Images" is set to allow (selecting Use Default should also work)

Next select the Media panel, then click on the first item in the list. Use the down arrow key to scroll through the list. If any item has the option "Block images from (domain name)" selected, de-select the option.

This should hopefully resolve your issue, but also see Fix problems that cause images to not show.

Some add-ons can also block images, for example if you have AdBlock Plus installed, make sure that you have not accidentally created a filter to block the images.

Read this answer in context 25

Additional System Details

This happened

Every time Firefox opened

This started when...

2 days ago

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • The BT Broadband Support Tools is part of the BT's Getting Setup Portal,as it provides additional help wizards for your BT Total Broadband product.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • Shockwave Flash 10.0 r42
  • iTunes Detector Plug-in
  • GEPlugin
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Motive Plugin for Mozilla Browsers
  • Google Update
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729)

More Information

TonyE
  • Moderator
1034 solutions 8840 answers

Chosen Solution

With Facebook on display, click on the site identity button (for details on that button see the How do I tell if my connection to a website is secure? article) and then on More Information. This will open up the page info dialog.

First select the Permissions panel, make sure that "Load Images" is set to allow (selecting Use Default should also work)

Next select the Media panel, then click on the first item in the list. Use the down arrow key to scroll through the list. If any item has the option "Block images from (domain name)" selected, de-select the option.

This should hopefully resolve your issue, but also see Fix problems that cause images to not show.

Some add-ons can also block images, for example if you have AdBlock Plus installed, make sure that you have not accidentally created a filter to block the images.

With Facebook on display, click on the site identity button (for details on that button see the [[site identity button]] article) and then on More Information. This will open up the page info dialog. First select the Permissions panel, make sure that "Load Images" is set to allow (selecting Use Default should also work) Next select the Media panel, then click on the first item in the list. Use the down arrow key to scroll through the list. If any item has the option "Block images from (domain name)" selected, de-select the option. This should hopefully resolve your issue, but also see [[Images or animations do not show]]. Some add-ons can also block images, for example if you have AdBlock Plus installed, make sure that you have not accidentally created a filter to block the images.

Question owner

Many thanks Tony - it worked and FB is looking normal again! Cheers

Many thanks Tony - it worked and FB is looking normal again! Cheers
TonyE
  • Moderator
1034 solutions 8840 answers

You're welcome

You're welcome
bklau 0 solutions 1 answers

Tried Site Identity ... Didn't work. :(

Tried Site Identity ... Didn't work. :(
cor-el
  • Top 10 Contributor
  • Moderator
11983 solutions 111347 answers

Helpful Reply

You can go to Tools > Page Info > Media

You can go to Tools > Page Info > Media