Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 2.o upgrade to 3.6 problem - Firefox 3.6.10.dm no mountable filesystems. Fails to mount Mac 10.3.9

  • 1 reply
  • 8 have this problem
  • 1 view
  • Last reply by TonyE

more options

Firefox 2.o upgrade to 3.6 problem - Firefox 3.6.10.dm no mountable filesystems. Fails to mount Mac 10.3.9

All Replies (1)

more options

Firefox 2.0.0.20 is the last version of Firefox that works on OS X 10.3.9, later versions of Firefox require at least OS X 10.4