X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I keep getting a strange "Sercure Connection Failed" message which reads "us.data.toolbar.yahoo.com:443 uses an invalid security certificate." Why is this happening and how do I fix it?

Posted

Started happing on my laptop and my PC the same night. Both machines worked fine for months before this. I did not install any updates or toolbars or anything. Weird that it would start happening on 2 computers at the same time.

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • 4.0.50826.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Java Plug-in 1.6.0_13 for Netscape Navigator (DLL Helper)
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3196 solutions 24401 answers

Chosen Solution

See this:
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

Helpful Reply

Thanks so much : )

It was a Yahoo toolbar extension. Problem went away when I disabled it following the directions from the link you provided.

Can't thank you enough.

Paul.

the-edmeister
  • Top 10 Contributor
  • Moderator
3196 solutions 24401 answers

You're welcome.

dit00@hughes.net 0 solutions 1 answers

Didn't work for me. It also won't let firefox end so before you can bring up firefox again after you have closed it, you must kill the process

 'firefox.exe *32' from the Windows task manager.
ChrisRich 0 solutions 1 answers

Wow.. I don't think your install is very happy. Have you tried a full reinstall?

I have tried full reinstalls, various versions, a portable install, nothing seems to work on my machine (and plenty of others) aside from going through the process with Chrome/IE/Safari/Opera (None of them have this issue).

The site I'm trying to sort out is here: http://www.theprivateplatecompany.co.uk/

They have two options for buying on the site and the second one will take you to a payment page: http://i.imgur.com/GIzWp.png

Almost all Plugins are disabled: http://imgur.com/xXeE6.png (ALL Add-ons are disabled)

And this is the current version I am testing with: http://imgur.com/adyCX.png

I've searched high and low and tried all suggestions without figuring it out.

I have people with Firefox telling me that when they hit the secure page it doesn't have that error, so it's not all the time, but it's ONLY Firefox.. ?!

So odd.. :)

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

There is a problem with the certificate of the www.secureonlinepurchasing.co.uk site.
The server doesn't send a required intermediate certificate (GeoTrust DV SSL CA).
You can check that via http://www.networking4all.com/en/support/tools/site+check/

See https://knowledge.geotrust.com/support/knowledge-base/index?page=content&id=AR1422

rorigiles 0 solutions 2 answers

Hi Everyone I had the same problem but I finally got rid of it. I was getting more or less the same message, my passwords to my yahoo emails and my yahoo news site was not being saved and I had to log in every time I started my Firefox browser and the print on my homepage and its news items kept reverting to small print. The cause of the problem was a Yahoo email notification app that I had (Yahoo Mail Watcher 1.42). I discovered this by first uninstalling Firefox and any left over components from the uninstall (these I did manually) and telling Firefox to delete all of my bookmarks, passwords etc etc. I then reinstalled Firefox and did not reinstall my email app. Everything worked fine. I then did a test to assure myself that it was indeed the yahoo email notification app by downloading the app again. As soon as I did this I had the problem back again. I then went through the whole process of uninstalling and reinstalling Firefox again and once again the problems disappeared. I hope that this is helpful for you.

Sudheer 0 solutions 1 answers

Same tool bar problem...Help --Troubleshooting info --Profile Directory(Open containing folder) --Extension (Deleted yahoo tool bar)

Modified by Sudheer