X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I live in Greece. Firefox comes up in Greek . I want English Please help

Posted

I want Firefox to have google.com as a homepage. Instead it reverts to google .gr, and the whole page is Greek. I would like English. Please help.

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • Shockwave Flash 10.0 r45
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)

More Information

LlelanD 0 solutions 11 answers

From the menu, go to Tools | Options and click the General tab in the Options dialog. Type "http://www.google.com" into the "Home Page" field and click OK. This will make that English page your default home page.

Question owner

Thanks a lot LlelanD it works!