X
Tap here to go to the mobile version of the site.

Support Forum

The font/text in the menu bar and tab titles look like crap.

Posted

Because my question involves the appearance of firefox, I have taken screenshots and posted them on a free image hosting service. After clicking the link, click the image to view it in full-size.

Figures 1-3 Figures 4-5

I am running Windows 7, and Firefox 4.0 Beta 6.

I recently turned off cleartype, but because Segoe UI is designed for it, I switched my default system font to Tahoma. Now all my fonts in all my programs are much clearer. There is only one program that didn't follow-suit, and that is firefox.

Figure 1 is an example of the font issues with firefox, figures 2 and 3 are examples of the same font displaying without any issues in Windows Explorer and IE. In figure 1, note how the vertical line letters such as 'i', 'k', and 'l' look terrible next to other letters, as in Edit and Tools.

Figures 4 and 5 are enlarged examples. The letters in the exact same word, 'Tools', using the same font, Tahoma, are all squished together in Firefox. It also appears the word is 3 or 4 pixels shorter in width, while being the same height. It is as if Firefox is trying to force a font size of 9, while the rest of my system uses 10.

''Because my question involves the appearance of firefox, I have taken screenshots and posted them on a free image hosting service. After clicking the link, click the image to view it in full-size.'' [http://img836.imageshack.us/i/013examples.jpg/ Figures 1-3] [http://img830.imageshack.us/i/02zoomedexample.jpg/ Figures 4-5] I am running Windows 7, and Firefox 4.0 Beta 6. I recently turned off cleartype, but because Segoe UI is designed for it, I switched my default system font to Tahoma. Now all my fonts in all my programs are much clearer. There is only one program that didn't follow-suit, and that is firefox. Figure 1 is an example of the font issues with firefox, figures 2 and 3 are examples of the same font displaying without any issues in Windows Explorer and IE. In figure 1, note how the vertical line letters such as 'i', 'k', and 'l' look terrible next to other letters, as in Edit and Tools. Figures 4 and 5 are enlarged examples. The letters in the exact same word, 'Tools', using the same font, Tahoma, are all squished together in Firefox. It also appears the word is 3 or 4 pixels shorter in width, while being the same height. It is as if Firefox is trying to force a font size of 9, while the rest of my system uses 10.

Chosen solution

Such issues can be caused by Direct2D.

Direct2D & DirectWrite HW Acceleration For Minefield - Info: http://forums.mozillazine.org/viewtopic.php?f=23&t=1775755

You can try to disable D2D:
Tools > Options > Advanced : General: Browsing: "Use hardware acceleration when available"

You can also set the pref mozilla.widget.render-mode to 0 (default is -1) on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r85
  • 4.0.50917.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Version 1.1.4, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

More Information

Application Basics
Name
Firefox
Version
4.0b6
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Personas
1.5.3
false
personas@christopher.beard
Feedback
1.0.3
true
testpilot@labs.mozilla.com
Modified Preferences
Name
Value
accessibility.typeaheadfind
true
accessibility.typeaheadfind.casesensitive
1
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.tvtorrents.com/loggedin/my/new_fav_torrents.do
browser.startup.homepage_override.buildID
20100914073604
browser.startup.homepage_override.mstone
rv:2.0b6
extensions.lastAppVersion
4.0b6
font.default.x-western
sans-serif
font.minimum-size.x-western
14
font.name.monospace.x-western
Tahoma
font.name.sans-serif.x-western
Tahoma
font.name.serif.x-western
Tahoma
font.size.fixed.x-western
14
font.size.variable.x-western
14
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
64377
places.last_vacuum
1282091669
print.print_printer
HP Deskjet 6980 (living room)
print.printer_HP_Deskjet_6980_(living_room).print_bgcolor
false
print.printer_HP_Deskjet_6980_(living_room).print_bgimages
false
print.printer_HP_Deskjet_6980_(living_room).print_command
print.printer_HP_Deskjet_6980_(living_room).print_downloadfonts
false
print.printer_HP_Deskjet_6980_(living_room).print_edge_bottom
0
print.printer_HP_Deskjet_6980_(living_room).print_edge_left
0
print.printer_HP_Deskjet_6980_(living_room).print_edge_right
0
print.printer_HP_Deskjet_6980_(living_room).print_edge_top
0
print.printer_HP_Deskjet_6980_(living_room).print_evenpages
true
print.printer_HP_Deskjet_6980_(living_room).print_footercenter
print.printer_HP_Deskjet_6980_(living_room).print_footerleft
&PT
print.printer_HP_Deskjet_6980_(living_room).print_footerright
&D
print.printer_HP_Deskjet_6980_(living_room).print_headercenter
print.printer_HP_Deskjet_6980_(living_room).print_headerleft
&T
print.printer_HP_Deskjet_6980_(living_room).print_headerright
&U
print.printer_HP_Deskjet_6980_(living_room).print_in_color
true
print.printer_HP_Deskjet_6980_(living_room).print_margin_bottom
0.5
print.printer_HP_Deskjet_6980_(living_room).print_margin_left
0.5
print.printer_HP_Deskjet_6980_(living_room).print_margin_right
0.5
print.printer_HP_Deskjet_6980_(living_room).print_margin_top
0.5
print.printer_HP_Deskjet_6980_(living_room).print_oddpages
true
print.printer_HP_Deskjet_6980_(living_room).print_orientation
0
print.printer_HP_Deskjet_6980_(living_room).print_page_delay
50
print.printer_HP_Deskjet_6980_(living_room).print_pagedelay
500
print.printer_HP_Deskjet_6980_(living_room).print_paper_data
1
print.printer_HP_Deskjet_6980_(living_room).print_paper_height
11.00
print.printer_HP_Deskjet_6980_(living_room).print_paper_size_type
0
print.printer_HP_Deskjet_6980_(living_room).print_paper_size_unit
0
print.printer_HP_Deskjet_6980_(living_room).print_paper_width
8.50
print.printer_HP_Deskjet_6980_(living_room).print_reversed
false
print.printer_HP_Deskjet_6980_(living_room).print_scaling
1.00
print.printer_HP_Deskjet_6980_(living_room).print_shrink_to_fit
true
print.printer_HP_Deskjet_6980_(living_room).print_to_file
false
print.printer_HP_Deskjet_6980_(living_room).print_unwriteable_margin_bottom
0
print.printer_HP_Deskjet_6980_(living_room).print_unwriteable_margin_left
0
print.printer_HP_Deskjet_6980_(living_room).print_unwriteable_margin_right
0
print.printer_HP_Deskjet_6980_(living_room).print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
4
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5700 Series
Vendor ID
1002
Device ID
68b8
Adapter RAM
1024
Adapter Drivers
aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version
8.771.0.0
Driver Date
8-25-2010
Direct2D Enabled
true
DirectWrite Enabled
true

cor-el
  • Top 10 Contributor
  • Moderator
13070 solutions 119681 answers

Chosen Solution

Such issues can be caused by Direct2D.

Direct2D & DirectWrite HW Acceleration For Minefield - Info: http://forums.mozillazine.org/viewtopic.php?f=23&t=1775755

You can try to disable D2D:
Tools > Options > Advanced : General: Browsing: "Use hardware acceleration when available"

You can also set the pref mozilla.widget.render-mode to 0 (default is -1) on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Such issues can be caused by Direct2D. Direct2D & DirectWrite HW Acceleration For Minefield - Info: http://forums.mozillazine.org/viewtopic.php?f=23&t=1775755 You can try to disable D2D:<br /> Tools > Options > Advanced : General: Browsing: "Use hardware acceleration when available" You can also set the pref mozilla.widget.render-mode to 0 (default is -1) on the about:config page. To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br />
TonyE
  • Moderator
1034 solutions 8840 answers

Helpful Reply

The mozilla.widget.render-mode preference works in beta 6, but this preference has now been removed from the latest development builds and will not work in beta 7 or later.

Removed by the part 2 patch for Bug 596494 – Update render mode on device removal

The mozilla.widget.render-mode preference works in beta 6, but this preference has now been removed from the latest development builds and will not work in beta 7 or later. Removed by the part 2 patch for [https://bugzilla.mozilla.org/show_bug.cgi?id=596494 Bug 596494] – Update render mode on device removal

Question owner

cor-el,

Well I tried both at once, so I'm not sure which one it was, but it worked! My tabs and menu bar look just like everything else now! Hooray!

Thank you so much for your detailed, concise, effective, and hasty reply. I am impressed.

'''cor-el''', Well I tried both at once, so I'm not sure which one it was, but it worked! My tabs and menu bar look just like everything else now! Hooray! Thank you so much for your detailed, concise, effective, and hasty reply. I am impressed.

Modified by moeburn

beegeeblueboy 0 solutions 1 answers

Yes - Switching off the H A fixed it. I wonder though n what ways my browsing experience will be affected elsewhere? iPlayer etc.

Yes - Switching off the H A fixed it. I wonder though n what ways my browsing experience will be affected elsewhere? iPlayer etc.