Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get FF to always open all of my homepages?

  • 2 replies
  • 11 have this problem
  • 3 views
  • Last reply by annabat

more options

I am using FF v.3.6.10 & XP with Service Pack 3. I am always conscious of installing the latest updates available for all of my programs.

I use 4 homepages but occasionally when I open FF it only remembers my first homepage (which incidentally is http://www.google.com.au/firefox?client=firefox-a&rlz=1R0GGLL_en-GB). In an attempt to solve this issue, I uninstalled FF from the ‘Add or Remove Programs’ shortcut in the Control Panel and then downloaded the newest version straight from the internet. When this didn’t work, I uninstalled FF again but in Safe Mode, shut the computer down, after 5secs I restarted the computer in normal mode and then I re-installed FF. But the problem has still persisted.

Also, I have noticed in the Privacy settings the following are unchecked: Automatically start Firefox in a private browsing session, Remember search and form history & Clear history when Firefox closes.

Is there anything else that I can do so that FF continues to always open all of my homepages?

All Replies (2)

more options

Chosen Solution

more options

Thanks for your help. After reading those links and slowly working through the instructions I came to the conclusion that the Google Toolbar for Firefox 7.1.20100830W was the problem. It must of corrupted the localstore.rdf file in my Firefox profile. I then used the unofficial 'googlebar 0.9.20.03' and I haven't had any problems since. The instructions were easy to follow even for a novice like me. Cheers.