X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Error at start-up: JAVA Script what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

Posted

his message is displayed on Firefox start-up:

Box title is "JAVA Script Application"

what happened:TypeError: components.classes['@mozilla.org/extensions/manager;1'] is undefined

Additional System Details

This happened

Every time Firefox opened

This started when...

First time was on start-up at installation

Installed Plug-ins

  • Shockwave Flash 10.0 r42
  • GEPlugin
  • 4.0.50826.0
  • Rhapsody Player Engine Plugin
  • Google Update
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

More Information

Clicking "Show details »" below causes same error message

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

That is an indication that you have an incompatible add-on. Follow the procedure in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to identify the culprit.

fizzbowen 0 solutions 2 answers

Foxit Toolbar is a likely suspect if you started receiving this message recently. The error stopped happening for me the instant I disabled this add-on.

Modified by fizzbowen

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96695 answers

@ghosking

Your above posted system details show outdated plugin(s) with known security and stability risks.

  1. Shockwave Flash 10.0 r42
  2. Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers

Update the Java plugin to the latest version.

Update the Flash plugin to the latest version.

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

This could also be caused by the Ask Toolbar. Can you disable that and try again?

Dave G 15 solutions 95 answers

Helpful Reply

If you have the Ask Toolbar installed under Firefox 4.0b1+ it will give this error. The toolbar lies in its install manifest to say it is compatible with up to Firefox 5.* (you heard me) thus you'll need to disable or uninstall it. A blocklist request is pending...

Zaphod56 0 solutions 1 answers

It happens to me when I installed a new release of skype (5.5). Yust disable the plugin and the problem will fixed.

Modified by Zaphod56

4freebird 1 solutions 3 answers

I concur that the problem is an add-on that is incompatible with FF5. Disable it and reboot. Problem solved.

pimpdaddy 0 solutions 1 answers

Thank u very much for your post, cuz u were right on the money! After chasing the problem for hours last nite, installing, uninstalling etc.; I stumbled across your post here thankfully. Thank u once again!