X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash player video rendering problem

Posted

Hello I have a problem with my flash video. When I play YouTube video and scroll with my mouse wheel, the static part of the video is redrawn with the rest of the website. The dynamic part is rendered correctly. It's hard to explain it in words so, please, see the picture.

Does anyone have any idea how to fix it? Already tried to reinstall flash plugin.


Feel free to ask another info what you need to know to help me solve this issue.

Chosen solution

Firefox 4 Beta uses Direct2D GPU Acceleration try turning it off in about:config

change "mozilla.widget.render-mode" to 0.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.1 r82
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

More Information

Stručně o aplikaci
Název
Firefox
Verze
4.0b6
Adresář s profilem
Otevřít složku
Povolené zásuvné moduly
about:plugins
Nastavení sestavení
about:buildconfig
Rozšíření
Název
Verze
Povoleno
Id
Xmarks
3.8.7
true
foxmarks@kei.com
Close Tab By Double Click
1.12
true
close@doubleclick
České slovníky pro kontrolu pravopisu
1.0.1
false
cs@dictionaries.addons.mozilla.org
Adblock Plus
1.2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Feedback
1.0.3
true
testpilot@labs.mozilla.com
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Změněné předvolby
Název
Hodnota
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20100914073604
browser.startup.homepage_override.mstone
rv:2.0b6
extensions.lastAppVersion
4.0b6
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
193226
print.print_printer
Canon MP520 series Printer
print.printer_Canon_MP520_series_Printer.print_bgcolor
false
print.printer_Canon_MP520_series_Printer.print_bgimages
false
print.printer_Canon_MP520_series_Printer.print_command
print.printer_Canon_MP520_series_Printer.print_downloadfonts
false
print.printer_Canon_MP520_series_Printer.print_edge_bottom
0
print.printer_Canon_MP520_series_Printer.print_edge_left
0
print.printer_Canon_MP520_series_Printer.print_edge_right
0
print.printer_Canon_MP520_series_Printer.print_edge_top
0
print.printer_Canon_MP520_series_Printer.print_evenpages
true
print.printer_Canon_MP520_series_Printer.print_footercenter
print.printer_Canon_MP520_series_Printer.print_footerleft
&PT
print.printer_Canon_MP520_series_Printer.print_footerright
&D
print.printer_Canon_MP520_series_Printer.print_headercenter
print.printer_Canon_MP520_series_Printer.print_headerleft
&T
print.printer_Canon_MP520_series_Printer.print_headerright
&U
print.printer_Canon_MP520_series_Printer.print_in_color
true
print.printer_Canon_MP520_series_Printer.print_margin_bottom
0.5
print.printer_Canon_MP520_series_Printer.print_margin_left
0.5
print.printer_Canon_MP520_series_Printer.print_margin_right
0.5
print.printer_Canon_MP520_series_Printer.print_margin_top
0.5
print.printer_Canon_MP520_series_Printer.print_oddpages
true
print.printer_Canon_MP520_series_Printer.print_orientation
0
print.printer_Canon_MP520_series_Printer.print_page_delay
50
print.printer_Canon_MP520_series_Printer.print_paper_data
9
print.printer_Canon_MP520_series_Printer.print_paper_height
11,00
print.printer_Canon_MP520_series_Printer.print_paper_size_type
0
print.printer_Canon_MP520_series_Printer.print_paper_size_unit
1
print.printer_Canon_MP520_series_Printer.print_paper_width
8,50
print.printer_Canon_MP520_series_Printer.print_reversed
false
print.printer_Canon_MP520_series_Printer.print_scaling
0,60
print.printer_Canon_MP520_series_Printer.print_shrink_to_fit
false
print.printer_Canon_MP520_series_Printer.print_to_file
false
print.printer_Canon_MP520_series_Printer.print_unwriteable_margin_bottom
0
print.printer_Canon_MP520_series_Printer.print_unwriteable_margin_left
0
print.printer_Canon_MP520_series_Printer.print_unwriteable_margin_right
0
print.printer_Canon_MP520_series_Printer.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Grafika
Popis adaptéru
ATI Radeon HD 5700 Series
Id výrobce
1002
Id zařízení
68b8
Adaptér RAM
1024
Adaptér ovladače
atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Verze ovladače
8.723.0.0
Datum ovladače
4-6-2010
Direct2D povolen
true
DirectWrite povolen
true
(sorry for the czech troubleshooting info, it should be in english)

ThatNerd2049 1 solutions 6 answers

Chosen Solution

Firefox 4 Beta uses Direct2D GPU Acceleration try turning it off in about:config

change "mozilla.widget.render-mode" to 0.

Question owner

I tried to set it to zero and it helped. After setting it back to "-1" the problem returns. What exactly does this setting do? Is it safe to change it to zero for good? Thank you for your tip.

Modified by aldaris

ThatNerd2049 1 solutions 6 answers

Helpful Reply

Rendering for things like flash is normally done by the CPU.

Using the CPU for rendering flash works fine but the GPU is basically part of the video card or graphical chipset that handles all sorts of graphical operations.

Even though the CPU is fine for rendering flash using the GPU should be much faster but at this point in time its just to buggy for some users for practical use.

When Firefox 4 is out of beta this problem should hopefully be fixed but this is just speculation.

Changing it to zero for good should be fine.

Glad I could help you out. =)

Modified by ThatNerd2049

Question owner

OK I marked your first answer as it is a solution for this problem. But I have to give up Direct 2D GPU acceleration and I don't want to do that, because I like Direct2D benefits, so it's not a final solution for me. I'll also tried to update my graphic drivers but it didn't help. Just for the record, my graphic card is ATI Radeon HD 5700 Series (MSI R5770 (MS-V214)).

I'm moving to bugzilla now :)

kwolf 0 solutions 1 answers

I found this on google. I am having the same problem with the same GPU, ATi Radeon 5770. Am using latest Catalyst driver 10.9. Disabling GPU rendering seems to have fixed it... I hope this issue is resolved before Firefox 4 is released.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can help.

See http://jagriffin.wordpress.com/2010/08/30/introducting-grafx-bot/

Question owner

Seems the bug has been fixed in FF 4.0b7.

adiprenne 0 solutions 1 answers

i have same problem here in firefox 4.0 and i cannot find this mozilla.widget.render-mode in about:config.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

That is an old pref and is no longer used in current Firefox 4 builds.

Update the video display driver to the latest version. Disable hardware acceleration in Firefox 4.0: Tools > Options > Advanced : General: Browsing: [ ] "Use hardware acceleration when available"

If you are on Windows 7 then try:

Try to toggle some of the gfx and layers prefs on the about:config page to enable or disable some features.
Filter: /gfx|layers/


If you have a problem with Flash then try to dDisable the hardware acceleration in the Flash Player.
See Flash video won't play full screen on YouTube, Facebook and other websites

Flash "Display settings" window: